• May 15, 2024, 10:50:29 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: No DXS-3227 Forum so here goes...- CX4 Stacking Question  (Read 6896 times)

IanGW

  • Level 1 Member
  • *
  • Posts: 2
No DXS-3227 Forum so here goes...- CX4 Stacking Question
« on: May 15, 2010, 01:20:24 PM »

Hi All,

I've configured stacking on a core switch group that we have up and running here, and I've noticed that since configuring the CX4 backplanes using the DEM-411S kits, the WebUI is significantly slower, (and buggy).

I do the majority of the config through TFTP and terminal, but sometimes I need to quickly define a VLAN over the WebUI, and it seems a little weird.

Also, a question about the topology of stacking two switches (or more).

Should the CX4 cables be going from port 1/26 to 2/26 and 1/27 to 2/27, or 1/26 to 2/27 and 1/27 to 2/26?
Switch A is set as Unit 1, Port1: 26, Port2: 27; Switch B is set as Unit 2, Port1: 26, Port2: 27.


I've included a copy of the running config for notes:  I know it's a little messy, but I just configured stacking last night and have to clean up the etherchannels to our vSphere a little...

Code: [Select]
cle-swa# show run
interface port-channel 3
spanning-tree cost 4
exit
interface range ethernet 1/(3-7),2/(3-7,12)
spanning-tree disable
exit
interface range ethernet 1/3,2/(4-5,12)
spanning-tree cost 100
exit
interface range ethernet 1/(4-7),2/(3,6-7)
spanning-tree cost 4
exit
interface port-channel 1
description "16b iscsi e1-2"
flowcontrol on
exit
interface port-channel 3
description CLA-07-08-09-10
flowcontrol on
exit
interface port-channel 5
description atlas1data
exit                                       
interface port-channel 6
description atlas2data
exit
interface port-channel 7
description hermes3data
exit
interface port-channel 8
description hermes4data
exit
interface port-channel 9
description hermes3scsi
exit
interface port-channel 10
description hermes4scsi
flowcontrol on
exit
interface port-channel 12
flowcontrol auto
exit
interface port-channel 14
flowcontrol on
exit                                       
interface port-channel 15
description xServe
exit
interface ethernet 1/1
description "16b iscsi e1"
exit
interface ethernet 1/2
description "16b iscsi e2"
exit
interface ethernet 1/3
description "EQL-31-Alpha  C0 E0"
exit
interface ethernet 1/4
description "EQL-31-Alpha  C1 E1"
exit
interface ethernet 1/5
description "EQL-31-Alpha  C1 E2"
exit
interface ethernet 1/6
description "atlas1 qlogic e0"
exit
interface ethernet 1/7                     
description "atlas2 qlogic e0"
exit
interface ethernet 1/9
description "hermes3 bcm e0"
exit
interface ethernet 1/10
description "hermes3 intel e0"
exit
interface ethernet 1/11
description "hermes4 bcm e0"
exit
interface ethernet 1/12
description "hermes4 intel e0"
exit
interface ethernet 1/13
description "atlas1 bcm e0"
exit
interface ethernet 1/14
description "atlas1 intel e0"
exit
interface ethernet 1/15
description "atlas2 bcm e0"                 
exit
interface ethernet 1/16
description "atlas2 intel e0"
exit
interface range ethernet 1/(23-24)
description "LAG3 to cla-swa"
exit
interface ethernet 2/1
description "16b iscsi e3"
exit
interface ethernet 2/2
description "16b iscsi e4"
exit
interface ethernet 2/3
description "EQL-31-Alpha  C1 E0"
exit
interface ethernet 2/4
description "EQL-31-Alpha  C0 E1"
exit
interface ethernet 2/5
description "EQL-31-Alpha  C0 E2"
exit                                       
interface ethernet 2/6
description "atlas1 qlogic e1"
exit
interface ethernet 2/7
description "atlas2 qlogic e1"
exit
interface ethernet 2/9
description "hermes3 bcm e1"
exit
interface ethernet 2/10
description "hermes3 intel e1"
exit
interface ethernet 2/11
description "hermes4 bcm e1"
exit
interface ethernet 2/12
description "hermes4 intel e1"
exit
interface ethernet 2/13
description "atlas1  bcm e1"
exit
interface ethernet 2/14                     
description "atlas1 intel e1"
exit
interface ethernet 2/15
description "atlas2 bcm e1"
exit
interface ethernet 2/16
description "atlas2 intel e1"
exit
interface ethernet 2/19
description "xserve en0"
exit
interface ethernet 2/20
description "xserve en1"
exit
interface ethernet 2/23
description "A39 to cla-swa E9"
exit
interface ethernet 2/24
description "A40 to cla-swa E10"
exit
interface range ethernet 1/(1-2),2/(1-17)
flowcontrol on                             
exit
port jumbo-frame
interface port-channel 1
switchport mode general
exit
interface port-channel 3
switchport mode trunk
exit
interface port-channel 4
switchport mode trunk
exit
interface port-channel 7
switchport mode trunk
exit
interface port-channel 10
switchport mode general
exit
interface port-channel 14
switchport mode trunk
exit
interface port-channel 15
switchport mode general                     
exit
interface range ethernet 1/(1-2,8,17-24),2/(1-2,8,17-21,23-24,25-27)
switchport mode general
exit
interface range ethernet 1/(9-16,25-27),2/(9-16)
switchport mode trunk
exit
vlan database
vlan 80,180,200,210
exit
interface ethernet 1/1
switchport general pvid 210
exit
interface ethernet 1/2
switchport general pvid 210
exit
interface ethernet 1/17
switchport general pvid 200
exit
interface ethernet 2/1
switchport general pvid 210
exit                                       
interface ethernet 2/2
switchport general pvid 210
exit
interface port-channel 1
switchport general pvid 210
exit
interface port-channel 10
switchport general pvid 210
exit
interface range ethernet 1/(8,17-22),2/(8,17-18,21)
switchport general allowed vlan add 80
exit
interface port-channel 15
switchport general allowed vlan add 80
exit
interface range ethernet 1/(10-16),2/(10-16)
switchport trunk allowed vlan add 80
exit
interface range port-channel (3,14)
switchport trunk allowed vlan add 80
exit
interface range ethernet 1/(8,17-22),2/(8,17-18,21)
switchport general allowed vlan add 180
exit
interface port-channel 15
switchport general allowed vlan add 180
exit
interface range ethernet 1/(10-16),2/(10-16)
switchport trunk allowed vlan add 180
exit
interface range port-channel (3,14)
switchport trunk allowed vlan add 180
exit
interface ethernet 1/17
switchport general allowed vlan add 200 untagged
exit
interface ethernet 2/22
switchport access vlan 200
exit
interface range ethernet 1/(8,18-22),2/(8,17-18,21)
switchport general allowed vlan add 200
exit
interface port-channel 15
switchport general allowed vlan add 200     
exit
interface range ethernet 1/(10-16),2/(10-16)
switchport trunk allowed vlan add 200
exit
interface range port-channel (3,14)
switchport trunk allowed vlan add 200
exit
interface range port-channel (1,10)
switchport general allowed vlan add 210 untagged
exit
interface range ethernet 1/(3-7),2/(3-7)
switchport access vlan 210
exit
interface range ethernet 1/(8,17-22),2/(8,17-18,21)
switchport general allowed vlan add 210
exit
interface port-channel 15
switchport general allowed vlan add 210
exit
interface range ethernet 1/(10-16),2/(10-16)
switchport trunk allowed vlan add 210
exit                                       
interface range port-channel (3,14)
switchport trunk allowed vlan add 210
exit
interface vlan 80
name WAN
exit
interface vlan 180
name DMZ
exit
interface vlan 200
name VOIP
exit
interface vlan 210
name iSCSI
exit
interface range ethernet 1/(1-2),2/(1-2)
channel-group 1 mode on
exit
interface range ethernet 1/9,2/9
channel-group 7 mode auto
exit
interface range ethernet 1/(23-24),2/(23-24)
channel-group 3 mode auto
exit
interface range ethernet 2/(19-20)
channel-group 15 mode auto
exit
interface port-channel 1
gvrp enable
exit
interface port-channel 3
gvrp enable
exit
interface port-channel 7
gvrp enable
exit
interface port-channel 14
gvrp enable
exit
interface port-channel 15
gvrp enable
exit
interface range ethernet 1/(3,6-8,10-22,25),2/(8,10-18,21-22,25)
gvrp enable                                 
exit
gvrp enable
 interface port-channel 12
 negotiation 1000f
 exit
interface vlan 1
ip address 10.31.5.50 255.255.0.0
exit
hostname cle-swa
no logging console
snmp-server location "Closet E Switch A - Server Cabinet"
 snmp-server community fvdeszen ro view Default
 snmp-server community fvsnmp ro view Default
clock timezone -8
clock summer-time recurring usa
sntp client enable vlan 1
clock source sntp
sntp unicast client enable
sntp unicast client poll
sntp anycast client enable                 
sntp broadcast client enable
sntp server 10.31.0.1 poll
sntp server 10.31.253.1 poll
cle-swa#
Logged

Fatman

  • Poweruser
  • Level 9 Member
  • ****
  • Posts: 1675
Re: No DXS-3227 Forum so here goes...- CX4 Stacking Question
« Reply #1 on: May 17, 2010, 10:53:51 AM »

2 way
1/27 <-> 2/26
2/27 <-> 1/26

or 3 way
1/27 <-> 2/26
2/27 <-> 3/26
3/27 <-> 1/26

or for the pattern geeks...

from x=1 to x=n where n is the number of switches in the stack

(x) port 27 <-> ((x%n)+1) port 26

***Modified by Fatman, because typos abound.
Logged
non progredi est regredi

IanGW

  • Level 1 Member
  • *
  • Posts: 2
Re: No DXS-3227 Forum so here goes...- CX4 Stacking Question
« Reply #2 on: May 17, 2010, 01:56:32 PM »

Thanks Fatman, that looks like we have configured the topology correctly.  It was a little vague in the manual.

Any comment to the webUI being noticeably slower in stacking mode?  Is that just because the http server is polling all member switches each time it refreshes the webpage?

I have another issue, but I'll start another thread for that.
Logged