D-Link Forums

The Graveyard - Products No Longer Supported => Network and WIreless Adapters => DWA-652 => Topic started by: CaptPea on November 02, 2010, 03:11:33 AM

Title: Unable To Install 1.50 Drivers
Post by: CaptPea on November 02, 2010, 03:11:33 AM
Compaq Presario 2100US
D-Link DIR-655 Router
D-Link DWA-652 Adaptor Card

Drivers, vers 1.50, for DWA-65a

Windows Xp Home Editon SP3

Windows recognizes the new card. 

When trying to install drivers with D-Link Software, the software says the card can't be found.  I ignore that error and finish the install.  I reboot.  The card is listed by name in Device Manager.  It is unusable because "Windows cannot load the drivers" for the device.

When trying to manually install the drivers, Windows reports it can find the files.  This error msg is received after Windows has copied the files to the directory.  I reboot.  Device Manager still list the card as unusable.  I manually copy the drivers to the correct directory.  I reboot.  Still no luck.

I am trying to figure out why Windows Device Manager know the card is installed, but can't load the drivers.

Does anyone have any solutions to this card working?  It had worked before.