• August 13, 2022, 11:34:07 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: FTP Problems with DIR-655  (Read 2400 times)

hk1

  • Level 1 Member
  • *
  • Posts: 1
FTP Problems with DIR-655
« on: June 17, 2011, 12:46:14 PM »

One of the companies I work for uses a DIR 655 router. I'm having some trouble using FTP there.

Initially the problem was that FTP software would hang or give errors when trying to change directories on the remote server. This problem went away when I switched from passive FTP to Active FTP.

Now using Active FTP, the files appear to be uploaded with no problem. However, on closer inspection, the uploaded file has 0 bytes on the remote server.

We are uploading from a Windows 7 machine and uploading to our Web Hosting Company's Windows Server. I've actually written the one piece of software that is showing this problem but it uses a widely known open-source FTP library written in .NET. I've never encountered either of these problems with my software until I encountered the DIR-655.

The other FTP software client I've tried is FileZilla. It has the same problem, 0 bytes files when using Active FTP.

One solution I've seen on DSLReports was to disable the Stateful Packet Inspection part of the firewall (known as SPI). This is really not a good solution for two reasons. Number one, I do not have access to the router's firmware/configuration. Number 2, the company has a DIR-655 because they want the additional security. If we're going to disable SPI it just defeats one of the major purposes of owning the DIR-655.

Any ideas what we can do about this problem?
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49922
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: FTP Problems with DIR-655
« Reply #1 on: June 17, 2011, 12:53:49 PM »

Try setting Firewall settings to Endpoint Independent for both TCP and UDP.

Also have you set up any application rules or port forwarding rules for this FTP application? Might help to. Let us know what you find out.
Logged
Cable: 1Gb/50Mb>NetGear CM1200>DIR-882>HP 24pt Gb Switch. COVR-1202/2202/3902,DIR-2660/80,3xDGL-4500s,DIR-LX1870,857,835,827,815,890L,880L,868L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L,960L and 8000LH.