• November 29, 2021, 03:49:49 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Pages: [1] 2 3

Author Topic: DIR-882 Firmware v1.30  (Read 9253 times)

Paweł Kaczanowski

  • Level 1 Member
  • *
  • Posts: 1
DIR-882 Firmware v1.30
« on: June 02, 2020, 02:45:37 AM »

Today I received new firmaware v1.30 but I cant find anywhere complete changelog for this update. There are some secbugfixes in http://forums.dlink.com/index.php?topic=75413.0 but I bet this is nat all changes
Anyone anything?

DIR-882 HW:A1 FW:1.30
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49863
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: DIR-882 Firmware v1.30
« Reply #1 on: June 02, 2020, 08:56:33 AM »

The beta version you see here seems to be mostly a security fix:
http://forums.dlink.com/index.php?topic=75413.msg305873#msg305873

IF you are referring to a different version then I would contact your regional D-Link support office to ask about this.
Logged
Cable: 1Gb/50Mb>NetGear CM1200>DIR-882>HP 24pt Gb Switch. COVR-1202/2202/3902,DIR-2660/80,3xDGL-4500s,DIR-LX1870,857,835,827,815,890L,880L,868L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L,960L and 8000LH.

me_iauras

  • Level 2 Member
  • **
  • Posts: 74
Re: DIR-882 Firmware v1.30
« Reply #2 on: June 03, 2020, 03:39:06 AM »

No ... it seems to be the same version related to the bad HNAP implementation which allowed the password to be reset ; in the EU apparently D-Link decided to seed the "beta" to the automatic update servers . It's nice they've added WPA3 option and also option to no longer use WPA as that has been unsecured for a long time ( you couldn't choose only WPA2 before)

Here is the version.txt output:

Firmware External Version    V1.30
Firmware Internal Version:    V1.30B06
Date:    2020-04-21 09:55:49
Checksum    23568AA5
Kernel    linux 3.10.14 2020-04-21 09:55:49
HNAP Version    0202
WAN MAC:    28:3B:82:xx:xx:xx
LAN MAC    28:3B:82:xx:xx:xx
2.4GHZ WLAN MAC    28:3B:82:xx:xx:xx
5GHZ WLAN MAC    28:3B:82:xx:xx:xx
2.4GHz country code    EU 1,2,3,4,5,6,7,8,9,10,11,12,13
5GHz country code    EU 36,40,44,48,52,56,60,64,100,104,108,112,116,132,136,140,149,153,157,161
Firmware variant    Default
2.4GHZ SSID    
5GHZ SSID    

There are still some issues with it however :

1. After a few min of inactivity the VPN connection stops any packets transmission even though the VPN link is stil up

2. Even though the 5 GHz channels 52,56,60,64 are listed as available in the version.txt summary in the actual Wifi Settings configuration page the available options to choose from manually skip from 48 straight to 149 ( 52,56,60,64,100,104,108,112,116,132,136,140 are missing ) even though DFS is enabled and I'm nowhere near an active radar (   https://imgur.com/ikNDRQI  ) . Might be normal for DFS/TPcchanels to only be available via Auto and not manually but it never chooses these channels

3.The router still checks @ UTC 00:47 every night for updates even though it's configured not to do it.
Syslog of nightly check:
2020-06-03 03:47:25 FOTA_CONFIG[28805]: mtk/fota_generate_config.c, main, 1064:
2020-06-03 03:47:25 FOTA_CONFIG[28805]: Execute config ACTION: config.
2020-06-03 03:47:25 FOTA_CONFIG[28805]: mtk/fota_generate_config.c, action_config, 779:
2020-06-03 03:47:25 FOTA_CONFIG[28805]: Now start generating the configuration file.
2020-06-03 03:47:25 FOTA_CONFIG[28805]: mtk/fota_generate_config.c, main, 1072:
2020-06-03 03:47:25 FOTA_CONFIG[28805]: Done.
2020-06-03 03:47:26 FOTA[28804]: fota_api_curl.c, get_http_response_code, 167:
2020-06-03 03:47:26 FOTA[28804]: iHttp_code=401.
2020-06-03 03:47:26 FOTA[28804]: fota_api.c, refresh_access_token, 214:
2020-06-03 03:47:26 FOTA[28804]: Now REFRESH the access token.
2020-06-03 03:47:27 FOTA[28804]: fota_api_curl.c, get_http_response_code, 167:
2020-06-03 03:47:27 FOTA[28804]: iHttp_code=200.
2020-06-03 03:47:27 FOTA[28804]: fota_api.c, refresh_access_token, 248:
2020-06-03 03:47:27 FOTA[28804]: REFRESH the access token success.
2020-06-03 03:47:28 FOTA[28804]: fota_api_curl.c, get_http_response_code, 167:
2020-06-03 03:47:28 FOTA[28804]: iHttp_code=200.
2020-06-03 03:47:28 FOTA_OUTPUT[28825]: mtk/fota_output.c, main, 339:
2020-06-03 03:47:28 FOTA_OUTPUT[28825]: Now processing the result of ACTION: auto.
2020-06-03 03:47:29 FOTA_OUTPUT[28825]: mtk/fota_output.c, handle_action_auto, 85:
2020-06-03 03:47:29 FOTA_OUTPUT[28825]: 'pUpdate_done_notify' is null pointer.
2020-06-03 03:47:29 FOTA_OUTPUT[28825]: mtk/fota_output.c, main, 344:
2020-06-03 03:47:29 FOTA_OUTPUT[28825]: The value of 'iRet' is not OK.

4 . still can't use 443 for Port Forwarding to a personal Web Server even though the router's remote management port has been changed to some other port or has been disabled entirely .

5. Scaling in the statistics tab still way off 
« Last Edit: June 03, 2020, 04:03:15 AM by me_iauras »
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49863
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: DIR-882 Firmware v1.30
« Reply #3 on: June 03, 2020, 08:00:05 AM »

I would contact D-Link support about these issues you see.

No ... it seems to be the same version related to the bad HNAP implementation which allowed the password to be reset ; in the EU apparently D-Link decided to seed the "beta" to the automatic update servers . It's nice they've added WPA3 option and also option to no longer use WPA as that has been unsecured for a long time ( you couldn't choose only WPA2 before)

Here is the version.txt output:

Firmware External Version    V1.30
Firmware Internal Version:    V1.30B06
Date:    2020-04-21 09:55:49
Checksum    23568AA5
Kernel    linux 3.10.14 2020-04-21 09:55:49
HNAP Version    0202
WAN MAC:    28:3B:82:xx:xx:xx
LAN MAC    28:3B:82:xx:xx:xx
2.4GHZ WLAN MAC    28:3B:82:xx:xx:xx
5GHZ WLAN MAC    28:3B:82:xx:xx:xx
2.4GHz country code    EU 1,2,3,4,5,6,7,8,9,10,11,12,13
5GHz country code    EU 36,40,44,48,52,56,60,64,100,104,108,112,116,132,136,140,149,153,157,161
Firmware variant    Default
2.4GHZ SSID    
5GHZ SSID    

There are still some issues with it however :

1. After a few min of inactivity the VPN connection stops any packets transmission even though the VPN link is stil up

2. Even though the 5 GHz channels 52,56,60,64 are listed as available in the version.txt summary in the actual Wifi Settings configuration page the available options to choose from manually skip from 48 straight to 149 ( 52,56,60,64,100,104,108,112,116,132,136,140 are missing ) even though DFS is enabled and I'm nowhere near an active radar (   https://imgur.com/ikNDRQI  ) . Might be normal for DFS/TPcchanels to only be available via Auto and not manually but it never chooses these channels

3.The router still checks @ UTC 00:47 every night for updates even though it's configured not to do it.
Syslog of nightly check:
2020-06-03 03:47:25 FOTA_CONFIG[28805]: mtk/fota_generate_config.c, main, 1064:
2020-06-03 03:47:25 FOTA_CONFIG[28805]: Execute config ACTION: config.
2020-06-03 03:47:25 FOTA_CONFIG[28805]: mtk/fota_generate_config.c, action_config, 779:
2020-06-03 03:47:25 FOTA_CONFIG[28805]: Now start generating the configuration file.
2020-06-03 03:47:25 FOTA_CONFIG[28805]: mtk/fota_generate_config.c, main, 1072:
2020-06-03 03:47:25 FOTA_CONFIG[28805]: Done.
2020-06-03 03:47:26 FOTA[28804]: fota_api_curl.c, get_http_response_code, 167:
2020-06-03 03:47:26 FOTA[28804]: iHttp_code=401.
2020-06-03 03:47:26 FOTA[28804]: fota_api.c, refresh_access_token, 214:
2020-06-03 03:47:26 FOTA[28804]: Now REFRESH the access token.
2020-06-03 03:47:27 FOTA[28804]: fota_api_curl.c, get_http_response_code, 167:
2020-06-03 03:47:27 FOTA[28804]: iHttp_code=200.
2020-06-03 03:47:27 FOTA[28804]: fota_api.c, refresh_access_token, 248:
2020-06-03 03:47:27 FOTA[28804]: REFRESH the access token success.
2020-06-03 03:47:28 FOTA[28804]: fota_api_curl.c, get_http_response_code, 167:
2020-06-03 03:47:28 FOTA[28804]: iHttp_code=200.
2020-06-03 03:47:28 FOTA_OUTPUT[28825]: mtk/fota_output.c, main, 339:
2020-06-03 03:47:28 FOTA_OUTPUT[28825]: Now processing the result of ACTION: auto.
2020-06-03 03:47:29 FOTA_OUTPUT[28825]: mtk/fota_output.c, handle_action_auto, 85:
2020-06-03 03:47:29 FOTA_OUTPUT[28825]: 'pUpdate_done_notify' is null pointer.
2020-06-03 03:47:29 FOTA_OUTPUT[28825]: mtk/fota_output.c, main, 344:
2020-06-03 03:47:29 FOTA_OUTPUT[28825]: The value of 'iRet' is not OK.

4 . still can't use 443 for Port Forwarding to a personal Web Server even though the router's remote management port has been changed to some other port or has been disabled entirely .

5. Scaling in the statistics tab still way off
Logged
Cable: 1Gb/50Mb>NetGear CM1200>DIR-882>HP 24pt Gb Switch. COVR-1202/2202/3902,DIR-2660/80,3xDGL-4500s,DIR-LX1870,857,835,827,815,890L,880L,868L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L,960L and 8000LH.

GreenBay42

  • Administrator
  • Level 11 Member
  • *
  • Posts: 2692
Re: DIR-882 Firmware v1.30
« Reply #4 on: June 03, 2020, 08:05:31 AM »

This firmware is the official based off the beta. It got pushed to FOTA servers the other day but they have not released the release notes. I will post as soon as I get them.
Logged

GreenBay42

  • Administrator
  • Level 11 Member
  • *
  • Posts: 2692
Re: DIR-882 Firmware v1.30
« Reply #5 on: June 10, 2020, 06:06:30 AM »

Finally got the release notes for v1.30B06:

Problems Resolved:
1. Fixed IOT issue with the specific cable modem.
2. Improved IOT issue with the specific client when SmartConnect is enabled.
3. Fixed the issue that the guest network time scheduling does not take effect.

Enhancements

1. Support WPA3
2. Support ISP profile in the Wizard for AU & SG countrycode for D-Link Wi-Fi APP
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49863
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: DIR-882 Firmware v1.30
« Reply #6 on: June 10, 2020, 08:24:17 AM »

Thank you Sir.  ;)
Logged
Cable: 1Gb/50Mb>NetGear CM1200>DIR-882>HP 24pt Gb Switch. COVR-1202/2202/3902,DIR-2660/80,3xDGL-4500s,DIR-LX1870,857,835,827,815,890L,880L,868L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L,960L and 8000LH.

psobolev

  • Level 1 Member
  • *
  • Posts: 1
Re: DIR-882 Firmware v1.30
« Reply #7 on: June 12, 2020, 06:45:33 AM »

After upgrading to 1.30 from 1.20 I noticed that several of my devices (2 Ring cameras and a networked printer) would no longer connect to my network, even after multiple attempts. I also noticed my WiFi signal dropping several times during the day on my MacBook. I downgraded back to 1.20 and now everything works fine.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49863
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: DIR-882 Firmware v1.30
« Reply #8 on: June 12, 2020, 09:37:25 AM »

Next time try a factory reset and setup from scratch after applying a FW update to see if the problem still continues.

After upgrading to 1.30 from 1.20 I noticed that several of my devices (2 Ring cameras and a networked printer) would no longer connect to my network, even after multiple attempts. I also noticed my WiFi signal dropping several times during the day on my MacBook. I downgraded back to 1.20 and now everything works fine.
Logged
Cable: 1Gb/50Mb>NetGear CM1200>DIR-882>HP 24pt Gb Switch. COVR-1202/2202/3902,DIR-2660/80,3xDGL-4500s,DIR-LX1870,857,835,827,815,890L,880L,868L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L,960L and 8000LH.

Iangho

  • Level 1 Member
  • *
  • Posts: 10
Re: DIR-882 Firmware v1.30
« Reply #9 on: July 05, 2020, 06:13:18 PM »

I have also reverted to 1.2 because it was causing the PPPoE connection to drop for a matter of seconds. Only noticed when audio streams were stopping and starting. Tried rebooting the modem and router but no good. Reverted to 1.2 and working fine.
Logged

kbuck320

  • Level 1 Member
  • *
  • Posts: 3
Re: DIR-882 Firmware v1.30
« Reply #10 on: July 05, 2020, 06:37:32 PM »

After upgrading to 1.30 from 1.20 I noticed that several of my devices (2 Ring cameras and a networked printer) would no longer connect to my network, even after multiple attempts. I also noticed my WiFi signal dropping several times during the day on my MacBook. I downgraded back to 1.20 and now everything works fine.

Same story here, but a frustrating mystery.  My 882 auto-updated and I didn't know.  I have a Chamberlin MyQ garage door hub that I found went off-line.  I tried a dozen times to get it connected to the DIR-882 and failed.  Finally, I realized the router had auto-updated around the same time the hub went offline. 

I downgraded to 1.20 and it immediately connected.  There's three hours of my life I'm not getting back.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49863
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: DIR-882 Firmware v1.30
« Reply #11 on: July 05, 2020, 09:00:18 PM »

Next time try a factory reset and setup from scratch after applying a FW update to see if the problem still continues.

I have also reverted to 1.2 because it was causing the PPPoE connection to drop for a matter of seconds. Only noticed when audio streams were stopping and starting. Tried rebooting the modem and router but no good. Reverted to 1.2 and working fine.
Logged
Cable: 1Gb/50Mb>NetGear CM1200>DIR-882>HP 24pt Gb Switch. COVR-1202/2202/3902,DIR-2660/80,3xDGL-4500s,DIR-LX1870,857,835,827,815,890L,880L,868L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L,960L and 8000LH.

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49863
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: DIR-882 Firmware v1.30
« Reply #12 on: July 05, 2020, 09:01:00 PM »

Next time try a factory reset and setup from scratch after applying a FW update to see if the problem still continues.

Same story here, but a frustrating mystery.  My 882 auto-updated and I didn't know.  I have a Chamberlin MyQ garage door hub that I found went off-line.  I tried a dozen times to get it connected to the DIR-882 and failed.  Finally, I realized the router had auto-updated around the same time the hub went offline. 

I downgraded to 1.20 and it immediately connected.  There's three hours of my life I'm not getting back.
Logged
Cable: 1Gb/50Mb>NetGear CM1200>DIR-882>HP 24pt Gb Switch. COVR-1202/2202/3902,DIR-2660/80,3xDGL-4500s,DIR-LX1870,857,835,827,815,890L,880L,868L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L,960L and 8000LH.

Iangho

  • Level 1 Member
  • *
  • Posts: 10
Re: DIR-882 Firmware v1.30
« Reply #13 on: July 05, 2020, 10:50:09 PM »

Next time try a factory reset and setup from scratch after applying a FW update to see if the problem still continues.

I'll stay on 1.2, I like an easy life. The functionality of 1.2 is fine for me.:)
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49863
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: DIR-882 Firmware v1.30
« Reply #14 on: July 06, 2020, 08:26:06 AM »

Next time you update though.

Logged
Cable: 1Gb/50Mb>NetGear CM1200>DIR-882>HP 24pt Gb Switch. COVR-1202/2202/3902,DIR-2660/80,3xDGL-4500s,DIR-LX1870,857,835,827,815,890L,880L,868L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L,960L and 8000LH.
Pages: [1] 2 3