• July 15, 2024, 11:59:35 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Wi-Fi Hotspot Mode won't work  (Read 10962 times)

ppdk

  • Level 1 Member
  • *
  • Posts: 18
Wi-Fi Hotspot Mode won't work
« on: April 29, 2014, 02:16:55 AM »

The reason for purchasing the DIR-505 is to make my personal network when traveling to hotels, so the Wi-Fi Hotspot Mode is the reason for purchasing it.

I received the DIR-505 today (purchased in Europe).
I upgraded the firmware from
Hardware version: A2 and Firmware version: 1.06
to
Hardware version: A2 and Firmware version: 1.08

using the file here (v1.08 B07):
http://www.dlink.com/de/de/support/product/dir-505-shareport-mobile-companion



Router/AP and Repeater modes work like a charm.

Unfortunately, I cannot get the Wi-Fi Hotspot to work. The LED is solid green, I went through the wizard and everything, I can see the newly created SSID in the list of networks, I can connect from a Windows 7 laptop (status is Connected) but is says No Internet access. On Firefox, typing a URL forwards me to the router configuration page.

On the iPhone, I can connect to the router's SSID, I even get the Wi-Fi icon, but when I try to access a web page (from Safari or Chrome on the iPhone), it says "webpage not available" then switches back and forth between 3G and Wi-Fi again.

Here are my settings on the home router to which the D-link connects:



Here are my settings on the DIR-505 router (pretty much the default settings) - I am trying to connect to SSID slow-wifi






Inspired by another thread, I then reset the router with a paper clip and went through the wireless wizard again, but the result is the same (even with a solid green LED).


What do I need to do to make it work? Is there any setting I need to change on the DIR-505?
« Last Edit: April 29, 2014, 02:36:08 AM by ppdk »
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49923
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Wi-Fi Hotspot Mode won't work
« Reply #1 on: April 29, 2014, 07:19:19 AM »

Does the 505 connect if you change the main host routers WiFi security from WPA2 TPIK to WPA/TPIK?
Try testing WPA2/AES only on the main host router then test the 505 for this mode as well.
Does the 505 connect to the main host router if you disable security on the WiFi as a temporary test?

Try testing the 505 with a different AP or host router, i.e. at friends, families place or coffee shop with WiFi. It's possible that the 505 maybe incompatible with this NG WiFi router.

When updating FW, please follow this process:
 FW Update Process

Logged
Cable: 1Gb/50Mb>NetGear CM1200>DIR-882>HP 24pt Gb Switch. COVR-1202/2202/3902,DIR-2660/80,3xDGL-4500s,DIR-LX1870,857,835,827,815,890L,880L,868L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L,960L and 8000LH.

ppdk

  • Level 1 Member
  • *
  • Posts: 18
Re: Wi-Fi Hotspot Mode won't work
« Reply #2 on: April 29, 2014, 12:49:42 PM »



Does the 505 connect if you change the main host routers WiFi security from WPA2 TPIK to WPA/TPIK?

When I do that on the main host router, the clients do connect but there is no internet connection, just like my initial problem.


Try testing WPA2/AES only on the main host router then test the 505 for this mode as well.

When I do that on the main host router, the clients do connect but there is no internet connection, just like my initial problem.

even when I change the DIR-505's setting in WIRELESS LAN SETUP / WPA
WPA Mode: WPA2 Only
Cipher Type: AES

Again, I get the connection but no internet access.


Does the 505 connect to the main host router if you disable security on the WiFi as a temporary test?

Yes, it does connect, and I do get internet access. The problem has to do with security indeed.


Try testing the 505 with a different AP or host router, i.e. at friends, families place or coffee shop with WiFi. It's possible that the 505 maybe incompatible with this NG WiFi router.

I did not have the opportunity to test that, but since it passes internet through when security is OFF on the main host router, I guess there is no compatibility issue with my home router.

Any other ideas to make the Hotspot Wi-Fi mode work when some level of security is active? I want to activate back my WPA2-PSK TPIK security.

Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49923
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Wi-Fi Hotspot Mode won't work
« Reply #3 on: April 29, 2014, 01:03:14 PM »

I recommend that you phone contact your regional D-Link support office and ask for help and information regarding this. We find that phone contact has better immediate results over using email.
Let us know how it goes please.
Logged
Cable: 1Gb/50Mb>NetGear CM1200>DIR-882>HP 24pt Gb Switch. COVR-1202/2202/3902,DIR-2660/80,3xDGL-4500s,DIR-LX1870,857,835,827,815,890L,880L,868L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L,960L and 8000LH.

ppdk

  • Level 1 Member
  • *
  • Posts: 18
Re: Wi-Fi Hotspot Mode won't work
« Reply #4 on: April 29, 2014, 11:45:27 PM »

Without calling customer support, I troubleshooted the issue myself.

The issue was that in QRS mobile, I gave the wrong Wi-Fi password for the host router. So it is normal that the D-Link router could not connect to the host router's protected Wi-Fi signal.

If D-Link developers are listening here, a simple enhancement would be to test the Wi-Fi password, and if it does not match, then put an error message: "D-Link DIR-505 could not connect to your host router because the password was not recognized. Please try again with the right password".

In a nutshell, a more user friendly interface. Not knowing where the error comes from is a pure time waster.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49923
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Wi-Fi Hotspot Mode won't work (RESOLVED)
« Reply #5 on: April 30, 2014, 07:59:26 AM »

Be sure you are using the lastest QRS mobile app.

This also would have helped if you had specified this app as well...

We presume mostly that users use the web UI connected to the 505 directly.

Glad you figured it out and its working now.

Enjoy.  ;)
Logged
Cable: 1Gb/50Mb>NetGear CM1200>DIR-882>HP 24pt Gb Switch. COVR-1202/2202/3902,DIR-2660/80,3xDGL-4500s,DIR-LX1870,857,835,827,815,890L,880L,868L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L,960L and 8000LH.

ppdk

  • Level 1 Member
  • *
  • Posts: 18
Re: Wi-Fi Hotspot Mode won't work
« Reply #6 on: April 30, 2014, 08:04:55 AM »

Yes, I am using the latest version of the QRS app.

I started by using the web UI, but then found using the QRS app was more straight forward.

I re-iterate my comment that the interface (regardless web UI or QRS app) needs to be more user friendly, eg. put up a warning when Wi-Fi password does not match.

Thanks.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49923
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Wi-Fi Hotspot Mode won't work
« Reply #7 on: April 30, 2014, 08:24:44 AM »

Is this for iPhone or Android?
Logged
Cable: 1Gb/50Mb>NetGear CM1200>DIR-882>HP 24pt Gb Switch. COVR-1202/2202/3902,DIR-2660/80,3xDGL-4500s,DIR-LX1870,857,835,827,815,890L,880L,868L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L,960L and 8000LH.

ppdk

  • Level 1 Member
  • *
  • Posts: 18
Re: Wi-Fi Hotspot Mode won't work
« Reply #8 on: April 30, 2014, 08:27:14 AM »

I use the Android app, but also have the iPhone one installed.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49923
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Wi-Fi Hotspot Mode won't work
« Reply #9 on: April 30, 2014, 08:34:56 AM »

And do the both exhibit this issue of not notifying of incorrect PW when connecting?
Logged
Cable: 1Gb/50Mb>NetGear CM1200>DIR-882>HP 24pt Gb Switch. COVR-1202/2202/3902,DIR-2660/80,3xDGL-4500s,DIR-LX1870,857,835,827,815,890L,880L,868L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L,960L and 8000LH.

ppdk

  • Level 1 Member
  • *
  • Posts: 18
Re: Wi-Fi Hotspot Mode won't work
« Reply #10 on: April 30, 2014, 09:09:58 AM »

I guess so. I don't recall that the web UI notifies this either - hence the problem I had initially.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49923
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Wi-Fi Hotspot Mode won't work (RESOLVED)
« Reply #11 on: April 30, 2014, 09:16:42 AM »

Ok, either way, I'll pass this on to D-Link.

Thanks for the feed back.

Enjoy.
Logged
Cable: 1Gb/50Mb>NetGear CM1200>DIR-882>HP 24pt Gb Switch. COVR-1202/2202/3902,DIR-2660/80,3xDGL-4500s,DIR-LX1870,857,835,827,815,890L,880L,868L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L,960L and 8000LH.