• June 20, 2024, 10:02:01 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: cant forward ports 443 or 4125  (Read 8138 times)

toony

  • Level 1 Member
  • *
  • Posts: 3
cant forward ports 443 or 4125
« on: August 12, 2009, 04:42:34 PM »

I'm having problems forwarding the ports 443 and 4125. I have forwarded port 80 to my server. The dir-655 says theyre open but when I check at sheildsUP! it says they are closed.


I'm setting up a Windows Home Server if that makes any difference. Which has a Web server built into it for server control and file sharing.... I have tried this with upnp on and off.


Any help would be great.
Logged

Demonized

  • Level 4 Member
  • ****
  • Posts: 421
Re: cant forward ports 443 or 4125
« Reply #1 on: August 13, 2009, 11:21:54 AM »

Firmware version would be nice, as well as your network topology. The DIR does not connect directly to the WAN, there's a gateway in between. Have you checked that?
Logged

Aurien

  • Level 1 Member
  • *
  • Posts: 7
Re: cant forward ports 443 or 4125
« Reply #2 on: August 13, 2009, 06:53:24 PM »

I suggest you call your ISP. Most ISP's block inbound connection on port 80. To try and keep people from setting up websites from their home connection. Depending on your ISP though you can maybe get it unblocked.

Other option is change the external port. If you look at port forwarding you list the external and internal port. Example. You could setup port 1547 to forward to your webserver port 80. So when accessing from outside your network it would be ip:port or url:port.
Logged

toony

  • Level 1 Member
  • *
  • Posts: 3
Re: cant forward ports 443 or 4125
« Reply #3 on: August 14, 2009, 04:39:28 AM »

I am running the latest firmware 1.32NA

I am running Windows Home Server and it has a self configuration utility for the webserver using uPnP and it used to work fine. I have upgrade the OS and then it would not self configure. Though the OS should not have anything to do with this. So I tried manually doing it. I was on firmware 1.2 which wasn't working.

So now I upgraded the firmware and now the ports wont open. The ISP does not block these ports.

Perhaps I should downgrade the firmware. and try again although it would not work with the older ones either.
Logged

bananaman

  • Level 2 Member
  • **
  • Posts: 55
Re: cant forward ports 443 or 4125
« Reply #4 on: August 14, 2009, 05:08:24 AM »

I'm running Windows Home Server with 1.32NA, but I'm not sure I can help because port forwarding is working! WHS tests it for you - why are you using ShieldsUP? Did you actually try to access WHS from outside your LAN?
Logged

smlunatick

  • Level 5 Member
  • *****
  • Posts: 625
Re: cant forward ports 443 or 4125
« Reply #5 on: August 14, 2009, 07:57:39 AM »

Be careful!!  D-Link has stated that any 655 with firmware 1.31 can not be downgraded to any older versions.  This might be the same for 1.32.
Logged

bananaman

  • Level 2 Member
  • **
  • Posts: 55
Re: cant forward ports 443 or 4125
« Reply #6 on: August 15, 2009, 07:15:41 AM »

You cannot downgrade from any 1.3x version to 1.2x or lower.
Logged

viinceennt

  • Guest
Re: cant forward ports 443 or 4125
« Reply #7 on: August 15, 2009, 10:07:08 AM »

yeah... the 1.3X firmware SUCKS!!! IT STINKS!!!! it makes a nice router into a crappy one... so yeah my router is crappy. i would not recommend anymore dlink products until they have a fix. :)
Logged

bananaman

  • Level 2 Member
  • **
  • Posts: 55
Re: cant forward ports 443 or 4125
« Reply #8 on: August 15, 2009, 11:41:18 AM »

I disagree. I've been running 1.3x since it was released, and other than having to disable DNS relay to prevent lockups, it has worked great for me.
Logged

toony

  • Level 1 Member
  • *
  • Posts: 3
Re: cant forward ports 443 or 4125
« Reply #9 on: August 15, 2009, 12:37:41 PM »

I'm running Windows Home Server with 1.32NA, but I'm not sure I can help because port forwarding is working! WHS tests it for you - why are you using ShieldsUP? Did you actually try to access WHS from outside your LAN?

I tried everything that I can think of and then some. There is some difference between the 120 trail WHS and the OEM version, so I have read. I was using Sheilds up to test my ports to see if that was part of the problem. It showed me that the 443 and 4125 ports were not opening even when I manually configure them, so if that's the case maybe it is'nt WHS but the router...... I dont know.
Logged

KevTech

  • Guest
Re: cant forward ports 443 or 4125
« Reply #10 on: August 15, 2009, 12:39:44 PM »

^^^^
+1
But mine runs great even with DNS relay on.
Logged

dioden

  • Level 1 Member
  • *
  • Posts: 5
Re: cant forward ports 443 or 4125
« Reply #11 on: August 15, 2009, 02:26:34 PM »

I tried everything that I can think of and then some. There is some difference between the 120 trail WHS and the OEM version, so I have read. I was using Sheilds up to test my ports to see if that was part of the problem. It showed me that the 443 and 4125 ports were not opening even when I manually configure them, so if that's the case maybe it is'nt WHS but the router...... I dont know.

Sorry to say but you're busted, you can't open ANY ports on that firmware, I have the same problem. :-(
Logged

bananaman

  • Level 2 Member
  • **
  • Posts: 55
Re: cant forward ports 443 or 4125
« Reply #12 on: August 15, 2009, 04:28:57 PM »

I have a bunch of ports forwarded with 1.32NA firmware, and they all work fine.
Logged

KevTech

  • Guest
Re: cant forward ports 443 or 4125
« Reply #13 on: August 15, 2009, 05:47:37 PM »

Windows firewall is on or off?
Logged

bananaman

  • Level 2 Member
  • **
  • Posts: 55
Re: cant forward ports 443 or 4125
« Reply #14 on: August 16, 2009, 06:08:20 AM »

Windows (Vista) firewall on.
Logged