D-Link Forums

The Graveyard - Products No Longer Supported => Routers / COVR => DIR-803 => Topic started by: network_guru on November 23, 2014, 04:11:19 PM

Title: router won't authencate without reboot
Post by: network_guru on November 23, 2014, 04:11:19 PM
803s been working flawlessly for 6 months. A couple of weeks ago, we started having problems with logging in to either the 2.4 or 5.0 band. After a lot of debugging and looking at packets going back and forth, found out that the router would not authenticate users after being on for 24 hours. As long as computers stayed connected, everything was fine. If any computer/phone disconnected and tried to reconnect, the device would associate with the 803, but would not authenticate with password.  Have updated to latest firmware without fixing the problem.

I first thought it might be a dhcp problem, but after giving all computers a fixed ip and dns servers, it still acted the same.  Have tried resetting to factory settings, with out joy. Tired moving it to a different location, no joy. Checked for other wifi access points that may be new in the neighborhood and made sure ours was on an unused channel. Tried different combinations of 802.11ac/a/b/d/n. No joy.

Being a network engineer, I can confirm the problem using Wireshark to inspect the packets to see what is going on.  You can see the device associating with the 803, password passed to 803, 803 disconnects.

The only temporary fix is to unplug the 803 (reboot). If I reboot daily, things seems to work until someone turns their computer off and tried to reconnect the next day.

I just need to find out how to return it and get if fixed.

Title: Re: router won't authencate without reboot
Post by: FurryNutz on November 23, 2014, 04:37:13 PM
Link>Welcome! (http://forums.dlink.com/index.php?topic=48135.0)

FW Update Process (http://forums.dlink.com/index.php?topic=42457.0)

Internet Service Provider and Modem Configurations

Wireless Configurations
Links>Wireless Installation Considerations (http://forums.dlink.com/index.php?topic=48327.0) and Managing Signal Congestion (http://forums.dlink.com/index.php?topic=53228.0) and Good Neighbour Policy (http://forums.dlink.com/index.php?topic=10634.0)
Try disabling the WiFi security as a quick temporary test, do devices connect? Re-enable after testing. This is only for a quick test.

Router Placement
Forum User - "Well I feel really dumb. After moving the router away from other electronic devices my speeds are back to normal. Just a heads up for anyone experiencing slow speeds, you might want to move it away from other electronics and see if that helps."
3-6' feet minimum safe distance between devices.
Placement on main level floor and central in the building and WELL ventilated is preferred. Not in basements or closets as building materials, or near by electronics devices could interfere or hinder good signal propagation.

Title: Re: router won't authencate without reboot
Post by: network_guru on December 06, 2014, 01:30:27 PM
Firmware 1.03
A factory reset was performed before and after firmware upgrade. Also numerous times after updated firmware.
Have given new SSID name, several times.
Have tried moving the router to different locations.
Have tried different channels.
Checked wifi routers around area for contamination.

I'm a network engineer. I work with routers all day long.
I used Wireshark to investigate what is happening.
Result: After unit makes the association with any device, device send authentication to router, router doesn't respond, but disconnects device.

This only happens after router is powered on for some length of time.
If I pull out the power cord in the morning, it works for most of the day, dropping devices occasionally.

My unit needs repaired. How do I get it repaired? Who do I call? The links on the website don't work. Where do I sent it?

The router is about 6 months old. Probably just our of warranty.
Title: Re: router won't authencate without reboot
Post by: FurryNutz on December 06, 2014, 03:47:28 PM

Internet Service Provider and Modem Configurations