• February 20, 2018, 01:58:56 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Pages: [1] 2 3

Author Topic: [1.20] DHCP assigns an IP not even in the same class... WTF???  (Read 1409 times)

heartsofwar

  • Level 2 Member
  • **
  • Posts: 28
[1.20] DHCP assigns an IP not even in the same class... WTF???
« on: November 25, 2017, 03:13:24 PM »

This is the third time I have seen this issue and the second time I have reported it. This router will randomly assign IP v4 addresses that aren't even in the same class.  The first time I saw it, the router would only issued IP v6 addresses...

The router is set to a class C IP range 192.x.x.x but randomly the router is issuing class B 169.x.x.x. Resetting the Router resolves the issue, but seriously D-Link... you need to do something about this. This is not a 1.20 or 1.15 firmware issue as the last time I saw this was back on 1.13. Just another reason I hate this damn router.
« Last Edit: November 25, 2017, 03:21:45 PM by heartsofwar »
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 44558
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Re: [1.20] DHCP assigns an IP not even in the same class... WTF???
« Reply #1 on: November 25, 2017, 03:15:53 PM »

The router doesn't issue a 169 address string, this is a device self assigned address string that happens on the client device when the device can't get a router based IP address from DHCP server.
http://packetlife.net/blog/2008/sep/24/169-254-0-0-addresses-explained/
« Last Edit: November 25, 2017, 03:19:17 PM by FurryNutz »
Logged
Cable:200mb/10Mb>Motorola MB7420>COVR3902>HP 24pt Gb Switch. 3xDGL-4500s,DIR-857,835,827,815,890L,880L,868L,865L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

heartsofwar

  • Level 2 Member
  • **
  • Posts: 28
Re: [1.20] DHCP assigns an IP not even in the same class... WTF???
« Reply #2 on: November 25, 2017, 03:22:21 PM »

Then tell me why the router is showing the device in the device list as 169?? This is a wireless device, so if it was auto-assigning 169 itself, the router wouldn't see it at all... I am not stupid. This router has major flaws
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 44558
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Re: [1.20] DHCP assigns an IP not even in the same class... WTF???
« Reply #3 on: November 25, 2017, 03:25:40 PM »

What is the device that seems to be getting this 169 address? Is it just one particular device or more than one?
Logged
Cable:200mb/10Mb>Motorola MB7420>COVR3902>HP 24pt Gb Switch. 3xDGL-4500s,DIR-857,835,827,815,890L,880L,868L,865L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

heartsofwar

  • Level 2 Member
  • **
  • Posts: 28
Re: [1.20] DHCP assigns an IP not even in the same class... WTF???
« Reply #4 on: November 25, 2017, 03:28:31 PM »

No, this has happened three times, once with IP v6 only addresses to my entire network, the router wouldn't even assign an IP v4 at all (over 20 devices). Second time was IP v4 class B being assigned to a wireless laptop, and this time class B assigned to a phone. Every time, the router shows the devices in the device list as though they are connected to the router, but obviously they do not talk. In both instances, the wireless devices are only one room away, there's no way its an interference / connectivity issue

1st time was 1.13 firmware (previously reported), 2nd time was 1.13 firmware, 3rd time 1.20 firmware
« Last Edit: November 25, 2017, 03:31:25 PM by heartsofwar »
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 44558
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Re: [1.20] DHCP assigns an IP not even in the same class... WTF???
« Reply #5 on: November 25, 2017, 03:33:50 PM »

What is the device that seems to be getting this 169 address? Mfr and model of phone and laptop and for Laptop or PC, what is the Mfr and model# of the wireless NIC?
Logged
Cable:200mb/10Mb>Motorola MB7420>COVR3902>HP 24pt Gb Switch. 3xDGL-4500s,DIR-857,835,827,815,890L,880L,868L,865L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 44558
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Re: [1.20] DHCP assigns an IP not even in the same class... WTF???
« Reply #6 on: November 25, 2017, 03:47:40 PM »

Have you tried loading DD-WRT using this build and version?
Path: Downloads › betas › 2015 › 10-09-2015-r27944 › dlink-dir895l
« Last Edit: November 25, 2017, 03:50:40 PM by FurryNutz »
Logged
Cable:200mb/10Mb>Motorola MB7420>COVR3902>HP 24pt Gb Switch. 3xDGL-4500s,DIR-857,835,827,815,890L,880L,868L,865L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

heartsofwar

  • Level 2 Member
  • **
  • Posts: 28
Re: [1.20] DHCP assigns an IP not even in the same class... WTF???
« Reply #7 on: November 25, 2017, 03:55:37 PM »

Phone is a Google Pixel 2 XL ( best guess Murata SS7715005 ) and the laptop is an Omen HP 1500t w/ intel 7260 wireless NIC.

No, Are you trolling me? You are more active on the DD-WRT forums since my last rant, you should know that the current state of DD-WRT support is that its a huge risk to being bricked...
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 44558
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Re: [1.20] DHCP assigns an IP not even in the same class... WTF???
« Reply #8 on: November 25, 2017, 04:04:48 PM »

Was any of these two devices updated recently?

What OS is on the laptop?
Maybe an issue at the client level if other devices are not experiencing this. Which leads me to think there is something going on with these devices. Even though they are not getting connected to the router, the router maybe seeing them anyways and detecting there addresses and reporting them in the UI. I have see this before on my 890L.

NO, options for getting something else loaded. I don't troll anyone on here. Trying to give you an option to try as an alternative since you complained before about WRT.
I found that recent WRT is failing to load on my DIR router. However I went back to 1st release and loaded Factory to WRT, then back to back loaded the same WebUpgrade file on top of Factory to WRT. Then used the UI to load most current version of WRT. Was a success on my DIR-868L.

Logged
Cable:200mb/10Mb>Motorola MB7420>COVR3902>HP 24pt Gb Switch. 3xDGL-4500s,DIR-857,835,827,815,890L,880L,868L,865L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

heartsofwar

  • Level 2 Member
  • **
  • Posts: 28
Re: [1.20] DHCP assigns an IP not even in the same class... WTF???
« Reply #9 on: November 25, 2017, 04:11:27 PM »

Laptop is running Fedora 26 now but was running Fedora 25 when it occured.

Well, when you can sucessfully load it on an 895L and it works or when more than one person on DD-WRT forums has success or there are more success stories than brick fails, I will try DD-WRT.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 44558
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Re: [1.20] DHCP assigns an IP not even in the same class... WTF???
« Reply #10 on: November 25, 2017, 04:17:06 PM »

Can you run Windows on this laptop and test? Wondering if this could be networking issue with in Linux...we haven't seen issues like this with others however they are running windows based OSs. Also something going on with this Google phone as well.

The issues is that users on WRT are loading recent version of WRT which seem to be broke with the most current version of factory to WRT file(2017). This is the same with my 868L. I could not get recent WRT to load. Also users are using the recover mode to load WRT which is bricking routers. I found that to get WRT to load correctly, you have to use the 1ST version of WRT they released(2015 for 895L), load the Factory to WRT first, then the same version of WebUpgrade file on top of it using the WRT UI. Then load the most current version, WebUpgrade using the WRT UI. This would be the best and safest method of getting WRT loaded. You can always revert to OEM using the recovery mode. Only use recovery mode for OEM loading FW though. NEVER for WRT.
« Last Edit: November 25, 2017, 04:22:37 PM by FurryNutz »
Logged
Cable:200mb/10Mb>Motorola MB7420>COVR3902>HP 24pt Gb Switch. 3xDGL-4500s,DIR-857,835,827,815,890L,880L,868L,865L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

heartsofwar

  • Level 2 Member
  • **
  • Posts: 28
Re: [1.20] DHCP assigns an IP not even in the same class... WTF???
« Reply #11 on: November 25, 2017, 04:30:26 PM »

uh... no, its not the laptop and the phone. To be quite honest and clear, I trust the phone and laptop way more than I trust this router. Its your device / firmware... The first issue I saw with this was network wide, over 20 devices. You want me to believe the router is not to blame and these devices are? Nope...
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 44558
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Re: [1.20] DHCP assigns an IP not even in the same class... WTF???
« Reply #12 on: November 25, 2017, 04:45:35 PM »

Can try loading WRT and see then...If not, I recommend that you phone contact your regional D-Link support office on Monday and ask for help and information regarding this. We find that phone contact has better immediate results over using email. Ask for an RMA if you feel the need.
Logged
Cable:200mb/10Mb>Motorola MB7420>COVR3902>HP 24pt Gb Switch. 3xDGL-4500s,DIR-857,835,827,815,890L,880L,868L,865L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 44558
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Re: [1.20] DHCP assigns an IP not even in the same class... WTF???
« Reply #13 on: November 27, 2017, 02:37:05 PM »

Logged
Cable:200mb/10Mb>Motorola MB7420>COVR3902>HP 24pt Gb Switch. 3xDGL-4500s,DIR-857,835,827,815,890L,880L,868L,865L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

heartsofwar

  • Level 2 Member
  • **
  • Posts: 28
Re: [1.20] DHCP assigns an IP not even in the same class... WTF???
« Reply #14 on: November 28, 2017, 10:42:08 AM »

I have to be honest, I do not like having DD-WRT pushed on me when its obvious your router firmware is to blame. I realize you are trying to find a solution for me that works, but I work from home and need my network up and running to do my job. What you are asking me to do runs the risk of bricking a very expensive router and disrupt my job. Are you and / or D-link willing to fully compensate the price I paid for this router if DD-WRT actions were to result in irrevocable failure? If not, I will try DD-WRT on my own time.

I already contacted your support by e-mail and was basically told I need to contact phone support. Again, more time and effort for a very expensive product that should just work.
Logged
Pages: [1] 2 3