• January 27, 2022, 06:24:27 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  


This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Permissions stop working randomly on one drive  (Read 991 times)


  • Level 1 Member
  • *
  • Posts: 7
Permissions stop working randomly on one drive
« on: August 12, 2019, 04:03:03 AM »

Hi everyone,

I appreciate this is an old product now, but hopefully someone can help.

I've had a DNS-323 for a long time now, no issues. But suddenly one of the drives is having odd permissions issues (I run it as two separate disks, not a RAID).

I connect to it via my laptop (Wi-Fi to router, NAS is plugged into the router directly if that matters) and I am unable to make any file changes to the first disk The second disk is fine, no issues... it's always the first disk.

Two computers connecting have the same issue. They can see the drive, just can't write to it.

Reboot the NAS, and all is fine... for less than a day then it does it again.

I've tried removing and re-adding the user, but that hasn't helped.

I run the scan disk feature but it says failed, but I'm not sure if that means the scan failed, the disk has failed... it's not very illuminating! And the disk is otherwise seemingly operational.

I'm perplexed! Any help appreciated.

Oh and I am using the Funplug thing so have terminal access.

Thanks in advance.


  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49886
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Permissions stop working randomly on one drive
« Reply #1 on: August 12, 2019, 09:38:42 AM »

Try a factory reset on the system and setup from scratch and see if it continues?
Cable: 1Gb/50Mb>NetGear CM1200>DIR-882>HP 24pt Gb Switch. COVR-1202/2202/3902,DIR-2660/80,3xDGL-4500s,DIR-LX1870,857,835,827,815,890L,880L,868L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L,960L and 8000LH.