• November 19, 2017, 12:50:43 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Can't forward ports  (Read 3907 times)

jerrylking

  • Level 1 Member
  • *
  • Posts: 10
Can't forward ports
« on: November 13, 2011, 07:39:18 AM »

I can't get port forwarding to work, even when I turn off the Windows 7 firewall and AVG anti-virus software I'm running.  I entered the IP address of my laptop (with a DHCP reservation) and UDP and TCP port numbers, with Schedule set to Always and Inbound Filter set to Allow All.  That should be it, right?  However, when I check the ports using PFPortChecker, both the UDP and TCP ports are blocked.  I do have a Linksys wireless router daisy-chained to the D-Link router, but I'm not communicating on this computer through the Linksys router and the problem still occurs even when the other router is disconnected, so that doesn't appear to have anything to do with the problem.  I just updated to the latest firmware (3.13NA).  I need to solve this problem so I can use a bit torrent application.  Suggestions?
Logged

Hard Harry

  • Guest
Re: Can't forward ports
« Reply #1 on: November 13, 2011, 07:55:40 AM »

Have you bypassed and gone direct to the modem? If that works it will rule out ISP, modem, and PC.
Logged

jerrylking

  • Level 1 Member
  • *
  • Posts: 10
Re: Can't forward ports
« Reply #2 on: November 13, 2011, 09:06:46 AM »

No, I haven't tried that, but I will.  I did try again using a different laptop running Windows XP, but got the same result.  I'll try connecting directly to the modem and see what happens.
Logged

jerrylking

  • Level 1 Member
  • *
  • Posts: 10
Re: Can't forward ports
« Reply #3 on: November 13, 2011, 06:13:45 PM »

Harry, again you pointed me in the right direction. I connected directly to the DSL modem, and still no joy.  Apparently the modem firewall is blocking the ports.  (I didn't even know the modem had a firewall.)  It also appears that my modem is so old (Sprint 660) that it does not offer the option of configuring the firewall to allow exceptions, and I cannot find a firmware update anywhere.  Looks like I will have to ask my ISP for a new modem.  This may take a while, but I'll post again when I have something to report.
Logged

Hard Harry

  • Guest
Re: Can't forward ports
« Reply #4 on: November 13, 2011, 10:22:04 PM »

Well don't forget to test the actual application, and not just rely on port tests. Most port test rely on java, or some other kind of plug in, which can be easily restricted by your AV. And I can't even blame the AV because of how many viruses use common bit torrent ports to come in on.

Before you start buying new hardware, try running the scanner while the computer is running in "Safe mode with networking" this will completely shut down any AV for the test. Usually you can get to the option by pressing F5 or F8 during boot. Just be sure to ONLY check those ports and reboot normally, because you will be vulnerable during that time.
Logged

jerrylking

  • Level 1 Member
  • *
  • Posts: 10
Re: Can't forward ports
« Reply #5 on: November 14, 2011, 09:05:02 AM »

OK, I tried again in safe mode, but ports are still being blocked.  This doesn't surprise me because I had tried earlier with my AV turned off.  However, there is one new thing to report--although my Sprint 660 modem does not provide an option to define exceptions to the firewall, it does have an option to toggle between router mode and bridge mode.  I switched to the bridge mode, using the default settings, but lost my internet connection.  I had to go back to the router mode and push the reset button on the modem to get my connection back.  From what I've gleaned from googling around, in principle I should be able operate the modem in bridge mode and stop it from blocking forwarded ports.  Is that correct?  Is it worth the time trying to figure out how to get it to operate in bridge mode?  Do my router settings need to be changed if I operate the modem in bridge mode?

Thanks very much for all of your help.
Logged

Hard Harry

  • Guest
Re: Can't forward ports
« Reply #6 on: November 14, 2011, 09:19:17 AM »

Yes, when you put your modem into bridge mode, you have to set to PPPoE, with your username and PW like your modem was set to. And yes, when your using a router, its a very good idea to set your modem to bridge. You may way to call your ISP to get your connection settings:

1. PPPoE, PPPoA, something else?
2. Dynamic IP or Static IP. If static, which IP
3. Username and password
4. Service name (if required)
5. MTU
Logged

jerrylking

  • Level 1 Member
  • *
  • Posts: 10
Re: Can't forward ports
« Reply #7 on: November 14, 2011, 12:19:10 PM »

Well, this is weird, and I don't know if it's OK or not.  I again set the modem to bridge mode, but through a different dialog box, and this time I got a message telling me to set my computer IP to 192.168.2.2 and reboot.  So, I logged into the router, but I couldn't see a way to change the external IP from what the DHCP had assigned earlier (192.168.2.3) to a new static address.  Just guessing, I hit the DHCP release button which zeroed out most everything, then DHCP renew.  It renewed with the external IP address of the modem, and the modem's DNS server.  I don't know if this is OK or not, but my internet connection works and my ports are no longer being blocked.  The only problem is that now I cannot access the modem.  However, as everything seems to be working, I don't need to.  Are there any security or other reasons I shouldn't just go with this?
Logged

Hard Harry

  • Guest
Re: Can't forward ports
« Reply #8 on: November 14, 2011, 12:36:15 PM »

Yea, not accessing the modem is normal, because now since its acting as a bridge, it doesn't have a assigned gateway, which means no IP to access it. But looks like you fixed it. Cool.
Logged

jerrylking

  • Level 1 Member
  • *
  • Posts: 10
Re: Can't forward ports
« Reply #9 on: November 14, 2011, 12:47:15 PM »

All right!  This was an adventure.  Thank you very much for your help.  ;D
Logged

Hard Harry

  • Guest
Re: Can't forward ports
« Reply #10 on: November 14, 2011, 01:00:42 PM »

No problem. Have fun!
Logged