• December 06, 2021, 04:39:33 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  


This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Windows 7 x86 Failed to map drive  (Read 6386 times)


  • Level 1 Member
  • *
  • Posts: 8
Windows 7 x86 Failed to map drive
« on: May 04, 2010, 12:16:22 PM »

Hi i've just found this forum by a quick search and thought i would ask a probably basic question i have as i have only just bought my 323.

I have a windows 7 x86 system that i use as my media center. I have my windows 7 box plugged into my router using a ethernet cable and also my 323 is pluged in using a ethernet. The 323 has only one drive a 2 tb wester digital green.

The problem i'm having is that the Easy storage Utily Drive mapping is failing.

I have downloaded and installed the latest firmware 1.08 and also i have version of the Easy storage Utily but still no luck. All i seem to get is "Failed to map drive". I have tried to access the drive through the ip address and also the username and it can't seem to access the 323. I can ping the 323 using the ip and also access the drives login using the but can't seem to be able to map a drive or anything to it. I have tried to use explorer map network drive using \\ but that just fails.

When running the util i do right click and run as admin

I ran the Easy storage Utily from a windows xp sp3 laptop using wifi and it works perfect.

I'm thinking it's something i've missed within windows 7 but not sure?
« Last Edit: May 04, 2010, 12:18:51 PM by obladeo »


  • Level 10 Member
  • *****
  • Posts: 2168
Re: Windows 7 x86 Failed to map drive
« Reply #1 on: May 04, 2010, 12:40:24 PM »

You perhaps have a firewall somewhere?  Or maybe Windows7 has been told not to trust the network (home or work network)?
RAID1 is for disk redundancy - NOT data backup - don't confuse the two.


  • Level 1 Member
  • *
  • Posts: 8
Re: Windows 7 x86 Failed to map drive
« Reply #2 on: May 04, 2010, 01:22:31 PM »

Hi i've checked the firewall and allowed access and also have the system set to home system.

I have just done a factory reset and got the "d-link network storage enclosure" to show in my device manager.

The problem is the drivers don't look right "The drivers for this device are not installed. (Code 28)"

On the hunt for some drivers now :s


  • Level 1 Member
  • *
  • Posts: 8
Re: Windows 7 x86 Failed to map drive
« Reply #3 on: May 04, 2010, 01:52:20 PM »

Hi i have now fixed this issue.

There seemed to be 2 issues 1 that the system didn't have the drive drivers. I'm in the uk and had to get the correct drivers from the dlink canadian site.


The next was that the windows network was not configured correctly.

Right click computer then properties
Then click advanced system settings
Then the computer name tag
Then Network ID...
Select this computer is part of a business network click NEXT
Select My computer uses a network without a domain click NEXT
Workgroup: WORKGROUP click NEXT
run d-link easy storage device Utility
And map your drive
Have a cup of tea as now
it's working