• March 01, 2024, 05:23:24 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Problems With NFS  (Read 29973 times)

ba43123

  • Level 1 Member
  • *
  • Posts: 2
Problems With NFS
« on: July 03, 2011, 04:21:57 AM »

I am trying to connect to my DNS-325 via NFS from both Linux and Mac OS X.  I have enabled NFS and set up Volume_1 as a NFS share that all users can read and write.

When I try to mount nas:/Volume_1 on either host I get "access denied by server".  On the DNS-325 I see the log message "NFS requested file or directory not in the exported list."

How do I get this to work?
Logged

ba43123

  • Level 1 Member
  • *
  • Posts: 2
Re: Problems With NFS
« Reply #1 on: July 03, 2011, 05:46:20 PM »

After spending most of the last hour on the phone with D-Link Technical Support, I came away with the recommendation to take my Mac (which has successfully connected to a number of NFS shares in the past) to Apple to determine if the network settings for NFS are correct.  This is mostly due to the fact that the people who are taking the calls have no information about NFS in their scripts and Knowledge Base so they are at a total loss in trying to provide any assistance.

The correct solution is as follows: Under Account Management > Network Shares, when you set up the share for NFS access a little icon appears in the Network Shares Settings table in the NFS column in the row for that share.  Although it does not appear to be a link, clicking the icon brings up a pop-up window with the settings for that share.  The critical item here is the string labelled "Real Path"; this is the string that needs to follow the host name.

As an example, if your DNS-325 has a host name of "nas" and you are sharing "Volume_1/nfs".  The correct string (at least on my box) to mount the share on Linux is "nas:/mnt/HD/HD_a2/nfs" and on the Mac is "nfs://nas/mnt/HD/HD_a2/nfs".  I suspect the "/mnt/HD/HD_a2/" part is dependent on how the disks are configured so be sure to look up the correct string for the share on your own DNS-325.
Logged

redpiyaya

  • Level 1 Member
  • *
  • Posts: 6
Re: Problems With NFS
« Reply #2 on: February 11, 2016, 09:17:23 AM »

I know this is an old post.

to fix this issue, Edit the share in the webui, in the NFS settings portion, when it ask for the HOSTNAME, enter 192.168.2.0/24 if your network is at 192.168.2.X.

The Hostname field is very misleading. This is actually a field that asks you on which network is allowed to access the NFS share.

This should work.

Email me if it helped.
mobilebri@gmail.com
Logged

cipsius

  • Level 1 Member
  • *
  • Posts: 1
Re: Problems With NFS
« Reply #3 on: April 22, 2017, 03:40:35 AM »

Hi, sorry to restart this thread.

I would like to thank you for the solution you offered, it worked. I have tried many different suggestions but yours is the only one that helped me with my DNS320L. Thank you again.

BR,
Cipsius
Logged

mfilos

  • Level 1 Member
  • *
  • Posts: 1
    • mfilos.com
Re: Problems With NFS
« Reply #4 on: April 26, 2017, 01:43:29 AM »

Sorry for the bump as well but I registered to say a huge THANKS cause this issue was driving me mad!
Cheers :D
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49923
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Problems With NFS
« Reply #5 on: April 26, 2017, 10:05:16 AM »

Glad it worked. Enjoy.  ;)
Logged
Cable: 1Gb/50Mb>NetGear CM1200>DIR-882>HP 24pt Gb Switch. COVR-1202/2202/3902,DIR-2660/80,3xDGL-4500s,DIR-LX1870,857,835,827,815,890L,880L,868L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L,960L and 8000LH.

Makdaddy

  • Level 1 Member
  • *
  • Posts: 8
Re: Problems With NFS
« Reply #6 on: May 30, 2022, 08:36:49 AM »

The /24. Fixed the issue on Kodi for me.
Simple up address in the host file didn't work.
Odd that permissions didn't cover all the up ranges in setup.
But hey thanks and cheers
Logged