• May 26, 2024, 02:08:54 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Are D-Link (or all) routers supposed to lose Wi-Fi access to an inactive bridge?  (Read 954 times)

Schmye Bubbula

  • Level 2 Member
  • **
  • Posts: 31

My primary router is a DIR-825, B1, 2.09NA.
I installed DD-WRT v3.0-r55630 std 4/3/24 on a Netgear WNDR3700v2 router, to use for, and only for, a Wi-Fi print server with a USB printer.
I configured DD-WRT as a, "Station Bridge (Routed)":
https://forum.dd-wrt.com/wiki/index.php/Client_Bridged
...which is wireless Wi-Fi only between the two routers, and the DD-WRT router thusly acting as a bridge can otherwise itself in turn only accept wired Ethernet connections (I have none) & the wired USB connection to my printer.

It works fine, *when* it works, but my problem is that after some time, usually after several hours, it always just ups & stops working. That is, wirelessly I can't access the USB printer, or get to the DD-WRT config webpage in my web browser wirelessly, or ping it wirelessly from terminal. The pattern is as follows:

Rebooting the DD-WRT router doesn't bring it back to life.
Rebooting the primary router, the DIR-825, will.
But the secondary router bridge has to already be running when booting the primary router; it won't bridge my network when booted after the primary router, which kinda defeats my purpose of wanting to be able to turn-on my printer & print server router bridge at any random time aarrgghh! (I don't understand; all my other Wi-Fi devices can join, leave, & rejoin my primary router at will no rebooting the primary router necessary. But I suppose wireless bridges must not connect in the same way as other devices.)
While it's "asleep" to all wireless attempts to connection by way of the primary router, plugging-in another wired device to an Ethernet port of the secondary Netgear router bridge will restore wireless access, and moreover keep it awake indefinitely. (But I don't want to keep something attached via Ethernet; I only want to use the bridge as a wireless print server.)
Whenever it's "asleep," while I can't ping it wirelessly as aforementioned, I *can* ping it from the ping utility built-in to my primary DIR-825 config webpage (settings > Tools > System Check > Ping Test).
Wireless access comes back to life all by itself after about half a day, following which it goes to sleep again after some time.... That got me thinking that maybe my primary D-Link's daily DHCP lease renewal was reactivating it (settings > Setup > Network Settings > DHCP Server Settings > DHCP Lease Time), but no, I changed it from 1440 minutes to 5 minutes, rebooted everything, waited until it "went to sleep" again, and it never awakened on its own. (I still would have to reboot the primary router, or plug-in an Ethernet device into to the secondary router bridge, or wait about half a day.) So I guess DHCP lease renewal only *checks* for an IP address still in use, not actually re-establishing connection as would occur at reboot. (I had temporarily given the secondary router bridge an IP address within my DHCP pool for the purposes of this little test, and even given that IP address a DHCP Reservation to try making double-sure, but, again, I guess bridges don't connect in the same way as other devices, as evidenced in my next point.)
I noticed that in my primary D-Link settings > Status > Device info > LAN Computers, my secondary router bridge's IP address is shown as 0.0.0.0, although right after a reboot it fleetingly shows the 192.168.0.x address I gave it, but it soon settles-down back to 0.0.0.0. I don't know what to make of that; is it normal? (Sometimes a couple of my other regular devices act oppositely: fleetingly show 0.0.0.0, but then they quickly return back to their usual IP addresses.)

So my main question is, does the DIR-825, or all D-Link routers peculiarly, or are routers generally supposed to "fall asleep" passing Wi-Fi access to a wireless network bridge after some period of inactivity of devices connected to that bridge? (Because, again, I have no wired Ethernet devices connected to it; only the USB printer, which doesn't seem to count.) I'm tearing my hair out trying to home-in on what I might be doing wrong, or what wrong expectations with this particular setup I might be harboring. Or is my problem some peculiarity with DD-WRT? (In which case I'll be cross-posting this on the DD-WRT forums, too.)
Logged