• June 02, 2023, 04:12:24 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  


This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Wi-Fi Problems with D-LINK DSL-G2562DG  (Read 1531 times)


  • Level 1 Member
  • *
  • Posts: 1
Wi-Fi Problems with D-LINK DSL-G2562DG
« on: May 17, 2022, 03:17:35 AM »


I wonder if anyone has any suggestions to help me with a strange problem.

I'm using the DSL-G2562DG (the one with 4 antenne) as a second router out of four.
The routers are used to extend the Wi-Fi coverage to the whole house. Only router 1 has the internet connection and DHCP
The Wi-Fi settings are all identical (yes I do know what I'm doing).

The network is as follows:
(Ip range 10.0.0.x Router 1 - Main Fibre connection with DHCP (separate room from house) Router 2 - DLINK router (bottom of house as daisy chain) Router 3 - Top of house end of line
Switch in garage from router 2 feeding Router 4 in offices above garage
Three work computers (DHCP)
Various wireless devices (DHCP) (Hikvision DVR) Grandstream 802 VoIP

So on router 2 the LAN ports are:
From router 1
To router 3
To garage switch
To Hikvision DVR in same cupboard

Everything on the LAN works perfectly and the Wi-Fi on all the routers. Devices roam fine between them


At times the DLINK will give issues with Wi-Fi.
Devices roam onto it and then may report "no internet" or "failed to obtain IP address".
Not all the time, it's only sometimes.
Walk away to another router coverage place and they work fine again.

Now, if I put a switch in place of the DLINK and run it off that (so only 1 LAN port used) then it never gives a problem.
If I use it as end of a LAN cable (e.g. router 3 or 4) then it is also fine.
Changing the 4 LAN cables around makes no difference. It will still have the problem at some point.
Right now I have it in place of a switch in the office as a test with two PCs on LAN and so far the Wi-Fi is fine.

When I had this problem the other day I ran a traceroute on my phone, and it could find router 3 and 4 but not router 1.

Why would I have this problem when there are 4 LAN cables plugged in but it works fine when only one is plugged in?
Or should I be looking at the other routers?  But then why is it only the DLINK wifi part that is the problem?
Their settings are all fine as well.
I have even tried a factory reset on each of them and started from scratch.
I have also downgraded the firmware on the DLINK to see if that makes a difference which it hasn't.

Any suggestions please.

The reason I don't want to add a switch is because we have load shedding here in South Africa, and I can't find a 12v switch to work off the battery I have to run the router (I have three batteries now - 1 for router 1 and fibre modem, 1 for router 2 and 1 for router 3).
Using router 3 or 4 in place of 2 won't work because for some reason then the VOIP system doesn't connect to the internet.

It's really rather complex I know so apologies if you have a headache now.

Thank you for your time to read this too, I really appreciate it

Regards, Pierre