• May 20, 2024, 10:43:10 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  


This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: device not found  (Read 8161 times)


  • Level 1 Member
  • *
  • Posts: 1
device not found
« on: October 19, 2018, 11:37:56 PM »

I tried to make the manual setup, I tried the WPS,
I get the solid green light, I can see the device on the devices connected on my router but the app always show "device not found".
I updated firmware of the smartplug, I tried to factory reset, nothing works.
I have 3 of them and all with the same problem.


  • Level 1 Member
  • *
  • Posts: 5
Re: device not found
« Reply #1 on: November 14, 2018, 06:21:51 PM »

I have the same problem. It can connect my D-link router (DIR-880L), but Mydlink Home app can't find it (Device not Found, Search Again).

I just received it today (Nov 14, 2018)

Help please ! Thanks.