• April 21, 2021, 11:38:15 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  


This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Access Point trouble with network switch  (Read 2433 times)


  • Level 1 Member
  • *
  • Posts: 1
Access Point trouble with network switch
« on: April 02, 2020, 03:52:44 PM »

I'll try and keep this concise but still detailed since my problem seems pretty strange.

Recently I got an ethernet cable running straight to my room since my router is multiple floors below me. In the past I was using my DAP-1620 on the floor below me, acting as a repeater off the router's wifi. Now that I have the hardwire in my room, I was hoping to connect the hardwire to my switch (specifically the D-Link GO-SW-5E). And then connect other devices and importantly the 1620 to the switch, in access point mode.

The problem is that when setup like that, the connection status repeatedly changes back and forth from Connected to Disconnected on the 1620 webpage. On the network switch, the activity light for the port flashes on then off, every second or so.

I've used different ports on the switch as well as different ethernet cables and nothing changed. I then assumed the switch was the issue, and connected the hardwire directly to the 1620. Fortunately that works but its not ideal...

To try and confirm if the switch was the issue, I put the 1620 back in repeating mode, and connected to my router's wifi. I ran an ethernet from the 1620 to my laptop, and I got the same connectivity issue. The ethernet connection appears in my network list, but then suddenly disappears (over and over again). About 2 weeks ago doing that worked.

I did some network tests when connected to the router's wifi with my laptop, with the 1620 setup in access point mode the way I initially described. I tried loading its webpage. It only loaded a white page with a few pieces of text that are meant to be buttons, and it took ages. I pinged the 1620 with command prompt, and most of the time it failed but occasionally went through with a really high latency.

I've reset the 1620 using the physical reset button. Just a note that I got the setup working for  a couple minutes in the first 10 minutes of trying to make it work, but then unplugged the switch to tidy up the cables. I haven't been able to replicate whatever I did to make it work.

DAP-1620 info:      HW:A2    FW:1.05

Thanks for reading, sorry for the wall of text.


  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49601
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Access Point trouble with network switch
« Reply #1 on: April 03, 2020, 02:05:16 PM »

Can you try a different switch? Try a D-Link DGS-105 or 108 in place if this other switch.
Is this other switch directly connected behind the main host router or are there any other switches in the chain or is it this one switch?

Ensure all LAN cables are in good working order and of good quality. CAT6 is recommended.

Try v1.06 FW and see.

Possible that the DAP maybe faulty.
Cable: 1Gb/50Mb>NetGear CAX80>DIR-882>HP 24pt Gb Switch. COVR-1202/2202/3902,DIR-2660/80,3xDGL-4500s,DIR-857,835,827,815,890L,880L,868L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L,960L and 8000LH.