• November 19, 2017, 12:44:12 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Disconnect every 20 minutes  (Read 2535 times)

Pakaa

  • Level 1 Member
  • *
  • Posts: 2
Disconnect every 20 minutes
« on: February 01, 2013, 06:25:52 PM »

Hi!

I have this annoying issue with my D-Link dir-645. Every 20 minutes, the system log says this:

Sat Feb 2 03:13:35 2013    Time synchronized
Sat Feb 2 03:13:28 2013    DHCP: Client receive ACK from 109.228.149.1, IP=81.170.185.104, Lease time=1200.
Sat Feb 2 03:13:28 2013    DHCP: Client send REQUEST, Request IP 81.170.185.104 from 109.228.149.1.
Sat Feb 2 03:13:28 2013    DHCP: Client receive OFFER from 109.228.149.1.
Sat Feb 2 03:13:28 2013    DHCP: Client send DISCOVER.

Which is exactly at the point where all PCs connected to the router will be disconnected from the web, and the time where the Connection Up Time in the web interface resets to 0.

This is with hardware version A1 and frimware 1.03. Running the connection through just the cord works just fine, as soon as the router in involved, we can't get more than 20 minutes of uptime. This is with factory default settings, and with pretty much every other setting we could imagine (disabled DNS relay, static IP, disabled clock syncronization, you name it, we've tried it). Now there's obviously something there with the lease time, the question we have is what can we do to have the router not loose connection whenever that expires?
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 43640
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Re: Disconnect every 20 minutes
« Reply #1 on: February 02, 2013, 09:43:34 AM »

Link>Welcome!

What region are you located?

Has a Factory Reset been performed?

What ISP Service do you have? Cable or DSL?
What ISP Modem make and model do you have?

Some things to try: - Log into the routers web page at 192.168.0.1. Use IE, Opera or FF to manage the router.
Turn off ALL QoS or Disable Traffic Shaping (DIR only) GameFuel (DGL only and if ON.) options. Advanced/QoS or Gamefuel.
Turn off Advanced DNS Services if you have this option under Setup/Internet/Manual.
Turn on DNS Relay under Setup/Networking.
Setup DHCP reserved IP addresses for all devices ON the router. Setup/Networking. This ensures each devices gets its own IP address when turned on and connected, eliminates IP address conflicts and helps in troubleshooting.
Ensure devices are set to auto obtain an IP address.
Set Firewall settings to Endpoint Independent for TCP and UDP under Advanced/Firewall.

Enable uPnP and Multi-cast Streaming under Advanced/Networking. Disable uPnP for testing Port Forwarding rules.
WAN Port Speed set to Auto or specific speed? Some newer ISP modems support 1000Mb so manually setting to Gb speeds can be supported by the router. Advanced/Advanced Networking/WAN Port Speed
Set Time and Time Zone under Tools/Time.

Link>Wireless Installation Considerations
What wireless modes are you using? Under Setup/Wireless/Manual.
Try single mode G or N or mixed G and N?
Channel Width set for Auto 20/40Mhz or try 20Mhz only.
Try setting a manual channel to a open or unused channel. 1, 6 or 11. 11 for single mode N if the channel is clear.
What security mode are you using? Preferred security is WPA-Personal. WPA2/AES Only. Some WiFi adapters don't support AES, so you might want to try TPIK only or Auto.
What wireless devices do you have connected?
Any cordless house phones?
Any other WiFi routers in the area? Link> Use InSSIDer to find out. How many?

Turn off WISH, and WPS under Advanced.
Try turning off Short GI, WLAN Partition,and Extra Wireless Protection if you have it. Under Advanced/Advanced Wireless.
Enable WMM Enable Under Advanced/Advanced Wireless.
Turn off all anti virus and firewall programs on PC while testing. 3rd party firewalls are not generally needed when using routers as they are effective on blocking malicious inbound traffic.
Turn off all devices accept for one wired PC while testing.

Check cable between Modem and Router, swap out to be sure. Link> Cat6 is recommended.
Logged
Cable:100mb/3Mb>Motorola SB6183>COVR3902>HP 24pt Gb Switch. 3xDGL-4500s,DIR-857,835,827,815,890L,880L,868L,865L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

Pakaa

  • Level 1 Member
  • *
  • Posts: 2
Re: Disconnect every 20 minutes
« Reply #2 on: February 02, 2013, 07:57:30 PM »

Solved it.

My ISP-provider (Swedish company 'Banhof') had two DNS servers that I had to dig up. By default there was only one DNS server set in Internet -> Manual Settings -> Dynamic IP (DHCP) Internet Connection Type. As soon as I set both DNS servers as primary and secondary, we haven't seen any disconnects since then.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 43640
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Re: Disconnect every 20 minutes (RESOLVED)
« Reply #3 on: February 04, 2013, 09:36:38 AM »

Glad you go it working.
Enjoy.
Logged
Cable:100mb/3Mb>Motorola SB6183>COVR3902>HP 24pt Gb Switch. 3xDGL-4500s,DIR-857,835,827,815,890L,880L,868L,865L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting