• October 02, 2023, 05:10:37 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  


This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Firmware upgrade caused some strange issues...  (Read 3927 times)


  • Level 1 Member
  • *
  • Posts: 1
Firmware upgrade caused some strange issues...
« on: April 03, 2021, 12:14:30 PM »

I was trying out how to share files inhouse using the USB port on my DIR-850L. I had a weird problem where my TV was able to connect but sometimes it would see an older state of the storage.
So to solve the issue I found a forum post here that among others suggested a firmware update. After nothing else worked I gave it a try. As my router had a realy old firmware on it still I followed some instructions downloading seperate firmwares and updating my router in the given order.
As a result when I log in to my routers settings I'm missing a good amount of it that previously worked. For example when I click on the "Connected Clients" nothing shows up, similarly on the "Shareport" page underneath the row with the save button nothing shows up anymore, and there are a handfull of other pages where nothing shows up.
On further examination it appears that I only have this problem with Chrome, where it sometimes adds the style "display: none;" to some of the divs... I'm not sure why it happens on Chrome, and why it only happens after the update.


  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49923
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Firmware upgrade caused some strange issues...
« Reply #1 on: April 04, 2021, 07:48:06 AM »


  • What Hardware version is your router? Look at sticker under the router case.
  • Link>What Firmware version is currently loaded? Found on the routers web page under status.
  • What region are you located?
  • Was a Factory Reset performed before and after any firmware updates then set up from scratch?
  Link> >FW Update Process

What other browsers have you tried?
Cable: 1Gb/50Mb>NetGear CM1200>DIR-882>HP 24pt Gb Switch. COVR-1202/2202/3902,DIR-2660/80,3xDGL-4500s,DIR-LX1870,857,835,827,815,890L,880L,868L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L,960L and 8000LH.