• November 29, 2021, 01:05:06 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: After FW upgrade, 5GHz not visible to mobile clients on Auto Channel  (Read 2221 times)

ashilur

  • Level 1 Member
  • *
  • Posts: 1

After FW upgrade, 5GHz not visible to mobile clients on Auto Channel

Backstory

This is a product purchased just last week from a reseller Star Tech located in Bangladesh, where D-Link is semi-officially present through the authorized agent UCC. I had brought it back to the seller Star Tech within two days of purchase, but was directed to its warranty department instead.

I filed the RMA and upon being called back to collect it, I requested to test and, perhaps not surprisingly, noticed that the incompetent "engineers" had simply reset the router with the problem in tact. I had written a complete problem description both in the online returns form and then physically on paper during my visit, but no-one bothered to read and comprehend. I convinced myself that "incompetent tech support" is a worldwide issue.

I had to then deny the service resolution and so was redirected to the RMA provider UCC. After many minutes of debating with an engineer that setting the channel manually to 149 was not a resolution I could accept, I was told to wait while they forwarded it to headquarters. I then spent two days over the phone and remote desktop to explain the problem to yet another engineer. Thankfully, this engineer saw the issue, but there was no immediate resolution.

Deferred Resolution Proposed by Local Agent

While the RMA engineer from UCC headquarters could see my problem after I walked him through the router and Windows network settings, he could only offer a verbal acknowledgment that he had reported it to D-Link upstream (Taiwan). He told me that they acknowledged the problem too and D-Link would strive to resolve it on their next FW release planned for mid-2021.

While I am very grateful to the local engineer for his effort, I have no proof of the proposed, deferred resolution, or if a resolution was being proposed at all, or if anyone from D-Link Taiwan had seen or said anything about my case. I have no way to phone the engineer back as the number is an IVR, but have left a message with D-Link Bangladesh on Facebook with the name (which thankfully I got over the phone).

My Request to D-Link and experts on this forum

I bought this router for its 160MHz support. I don't know how it could be marketed as an "AC2600" without 160MHz. Therefore, my problem resolution would be that 5GHz becomes visible to mobile clients on Auto Channel settings and 160MHz Bandwidth enabled. I would like to verify that D-Link is aware of this issue. I have no problem with a deferred resolution but I cannot accept no resolution at all, when I had to spend time, effort and money behind this product for availing after-sales services. I would like to know if there is any way I can communicate with upstream service personnel.

Problem Reproduction

  • Get router with stock FW 1.01.
  • Disable SmartConnect, name 2.4GHz and 5GHz SSIDs distinctively.
  • See that both bands are visible to computer and mobile clients.
  • Allow the router to upgrade multiple times (with restarts) to version 1.3.
  • See that DFS option exists. Ensure that Channel is set to Auto (otherwise DFS is not visible).
  • See that the 5GHz AC band is no longer visible to 5GHz-supported mobile smartphones of both the Android and iOS variety, sold in both North America and Asia.

Expected Resolution

  • Get router with stock FW 1.01.
  • Disable SmartConnect, name 2.4GHz and 5GHz SSIDs distinctively.
  • See that both bands are visible to computer and mobile clients.
  • Allow the router to upgrade multiple times (with restarts) to version 1.3.
  • See that DFS option exists. Ensure that Channel is set to Auto (otherwise DFS is not visible).
  • Enable DFS and set channel Bandwidth to Auto 20/40/80/160.
  • See that both bands are visible to computer and mobile clients, with 160MHz-unsupported devices being downgraded to lesser bandwidth with the help of 802.11ac frame-based negotiation.

Incorrect/Unacceptable Resolution

  • Get router with stock FW 1.01.
  • Disable SmartConnect, name 2.4GHz and 5GHz SSIDs distinctively.
  • See that both bands are visible to computer and mobile clients.
  • Allow the router to upgrade multiple times (with restarts) to version 1.3.
  • See that DFS option exists. Ensure that Channel is set to Auto (otherwise DFS is not visible).
  • See that the 5GHz AC band is no longer visible to 5GHz-supported mobile smartphones of both the Android and iOS variety, sold in both North America and Asia.
  • Set 5GHz Channel to 149, see that DFS option disappears.
  • See that 5GHz becomes visible to the mobile clients.
  • See that 160MHz (contiguous) is hidden and disabled, and therefore not functional on supported devices (a ThinkPad laptop).
  • Due to the manually preset Channel on 5GHz, router is no longer able to make its own decisions on allocating channels on the 5GHz band/spectrum, failing the design/intended specifications/behavior of the product, as the customer is unable to restore default/stock behavior.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49863
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: After FW upgrade, 5GHz not visible to mobile clients on Auto Channel
« Reply #1 on: November 25, 2020, 06:53:01 AM »

Link>Welcome!

  • Was a Factory Reset performed before and after any firmware updates then set up from scratch?
  Link> >FW Update Process

If official support lines have been used and HQ has been notified and they acknowledged the problem, then you'll need to wait for the next FW update to see if it's fixed. There is nothing that the forums can help with. In meantime, downgrade back to working FW version that works.
Logged
Cable: 1Gb/50Mb>NetGear CM1200>DIR-882>HP 24pt Gb Switch. COVR-1202/2202/3902,DIR-2660/80,3xDGL-4500s,DIR-LX1870,857,835,827,815,890L,880L,868L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L,960L and 8000LH.

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49863
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: After FW upgrade, 5GHz not visible to mobile clients on Auto Channel
« Reply #2 on: November 25, 2020, 09:03:40 AM »

Checking my 882 with v1.30 loaded, 5Ghz is seen using the configuration posted:
iPhone 12 Max:

Android Tab S2:




Logged
Cable: 1Gb/50Mb>NetGear CM1200>DIR-882>HP 24pt Gb Switch. COVR-1202/2202/3902,DIR-2660/80,3xDGL-4500s,DIR-LX1870,857,835,827,815,890L,880L,868L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L,960L and 8000LH.