• December 09, 2021, 06:01:30 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: shareport installation failed on 10.9.1  (Read 8913 times)

lono175

  • Level 1 Member
  • *
  • Posts: 5
shareport installation failed on 10.9.1
« on: January 31, 2014, 01:33:53 AM »

The installer says "installation failed: run postinstall script for SharePort Plus Installer."

I tried SharePort Plus 4.3 and 4.2.0. The error messages are the same.
« Last Edit: January 31, 2014, 06:02:00 AM by lono175 »
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49868
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: shareport installation failed on 10.9.1
« Reply #1 on: January 31, 2014, 07:46:51 AM »

Try switching from x64 bit mode to 32bit mode and try the installation of the SP software again...
Logged
Cable: 1Gb/50Mb>NetGear CM1200>DIR-882>HP 24pt Gb Switch. COVR-1202/2202/3902,DIR-2660/80,3xDGL-4500s,DIR-LX1870,857,835,827,815,890L,880L,868L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L,960L and 8000LH.

lono175

  • Level 1 Member
  • *
  • Posts: 5
Re: shareport installation failed on 10.9.1
« Reply #2 on: January 31, 2014, 08:03:29 AM »

I use the following command to switch to 32 bit:
"sudo systemsetup -setkernelbootarchitecture i386"

But the error message still persists.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49868
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: shareport installation failed on 10.9.1
« Reply #3 on: January 31, 2014, 08:31:12 AM »

Well I can check mine on my MBP 2007 LT. My SP has been already installed since 10.6 and I just applied the OSX updates over it so I've never had a need to re-install SP.

I recommend that you phone contact D-Link support and get some help on this. There could be an issue with the install and 10.9.1.

I'll see if I can test this this weekend.
Logged
Cable: 1Gb/50Mb>NetGear CM1200>DIR-882>HP 24pt Gb Switch. COVR-1202/2202/3902,DIR-2660/80,3xDGL-4500s,DIR-LX1870,857,835,827,815,890L,880L,868L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L,960L and 8000LH.

lono175

  • Level 1 Member
  • *
  • Posts: 5
Re: shareport installation failed on 10.9.1
« Reply #4 on: January 31, 2014, 09:02:02 AM »

I followed the steps in this link
http://forums.dlink.com/index.php?topic=5946.0;wap2

Then the error message goes away

******the solution*******
Pre Instructions:
If you have been trying without success I suggest you do the following before starting.
-Uninstall all versions of SX Virtual Link that you have installed. (use the uninstaller provided, or use appzapper  http://www.appzapper.com/)
-Uninstall all versions of D-Link Shareport that you installed. (same methods)
-delete all installation files of the above as to prevent confusion or mistakes (+empty trash)
-Close all, and restart.

1.A  In the System Preference in Mac, delete your printer.
1.B  Restart.
2.  Download and use Silex utility rather than the d-link re branded version.  Much more stable.
http://www.silexamerica.com/support/software/svl.html
2.B  restart.
3.  Start your printer first, open the utility and connect, print your document.
3.  To go from printing a document to scanning a document, you must disconnect the link, turn off the printer, and start again.  The utility does not work well with multifunction devices.
********************
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49868
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: shareport installation failed on 10.9.1 (RESEOLVED)
« Reply #5 on: January 31, 2014, 09:21:33 AM »

Enjoy.  ;)
Logged
Cable: 1Gb/50Mb>NetGear CM1200>DIR-882>HP 24pt Gb Switch. COVR-1202/2202/3902,DIR-2660/80,3xDGL-4500s,DIR-LX1870,857,835,827,815,890L,880L,868L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L,960L and 8000LH.

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49868
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: shareport installation failed on 10.9.1
« Reply #6 on: February 03, 2014, 11:49:18 AM »

Ok, so new version of SP that support OSX 10.9:
http://forums.dlink.com/index.php?topic=50708.0
Logged
Cable: 1Gb/50Mb>NetGear CM1200>DIR-882>HP 24pt Gb Switch. COVR-1202/2202/3902,DIR-2660/80,3xDGL-4500s,DIR-LX1870,857,835,827,815,890L,880L,868L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L,960L and 8000LH.