• June 26, 2022, 05:31:37 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  


This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Cannot resume from Standby / Hibernate problem  (Read 3606 times)


  • Level 1 Member
  • *
  • Posts: 5
Cannot resume from Standby / Hibernate problem
« on: October 24, 2008, 08:58:04 PM »

Had seen a few posts regarding this issue. Does not look like there is any solution. I had never expected this kind of problem given the fact that the device has been out for a couple of years now.

Is there anybody out there having this problem resolved?

I wanted a decently fast network storage system. The combination DNS-323 + DIR-655 + DWA-652 looked pretty good. So I jumped right in. The DNS and the router set up was good.
Then came the DWA-652.
I had sooooo much trouble with this thing to the point of giving up and return the whole combo.

Thought I put a few lines to share for the benefit to anyone with similar hardware as me.
I am running XP with SP3 on a Dell 710m.

1. Just in time debugger popped up when installing any of the the drivers from D-Link (tried them all)
2. Any attempt to disable the card will shut down Windows, followed by the infamous BSOD on subsequent reboot. Had to use the restore point.
3. Letting Windows manage the wireless seems to work only for a moment, the D-link utility takes it back soon after. It seems to have a mind of its own. Why ?
4. After a hibernate/standby, the JIT debugger popped up, then all the Network Connections disappeared. Have to reboot to get them back.
5. The fast user switching disappeared.
6. Tried the latest or not so latest driver from Atheros, with slightly better result.

At the end of it all, here is what I had settled with:

1. Download the latest driver from Atheros (version
2. Disable the internal wireless card.
3. Use msconfig to disable all services having anything to do with the internal wireless card.
4. Reboot the system for a clean start.
5. Install the Atheros driver and client utility.
6. Use Windows to manage the connection
7. Do not use Standby or Hibernate
8. Wait for a driver that will install and behave.

Update 27-Oct-2008.

1. Still working after one instance of BSOD which occurred when I accidentally disable the wireless during a file copy involving the network drive.

2. The fast user switching does not disappear this time as the Atheros driver was installed without the Client Utility.

Hoping that this will help someone.

« Last Edit: October 27, 2008, 05:55:45 PM by pixelnut »