• November 29, 2021, 01:26:58 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: DWA-652 slow * cpu at 100%  (Read 21711 times)

Frioniel0801

  • Guest
DWA-652 slow * cpu at 100%
« on: October 22, 2008, 01:28:23 AM »

Hi. I just received my DWA-652 NIC card today.

I installed the lastest driver and now everything is working. The speed is at 300 mbps.

However, the speed is still quite slow (if not faster than my old g-internal card) but I notice that it takes considerably longer to 'load up' a page from my explorer where as my old internal card would open the page up right away. ( I have enabled wireless-n on my dir-655 router. . . may be it's just me)

1. Any ideas why it takes longer to open up a page from explorer ? (settings perhaps ?)

2. I was gaming just now and my cpu shot up to 100% usage and it all froze. Any reason ? thanks ! (I've seen some thread about this and update my driver to atheros v7) please help.
« Last Edit: October 22, 2008, 01:36:53 AM by Frioniel0801 »
Logged

Frioniel0801

  • Guest
Re: DWA-652 slow * cpu at 100%
« Reply #1 on: October 22, 2008, 02:38:47 AM »

Sorry about the double post.

I've tried the solution suggested here in the forum. I've uninstalled the d-link wireless manager and enabled the windows one.

Is that correct ? Or do I retain the d-link wmanager ?

1. Uninstaller D-Link DWA-652 product
2. reinsert dwa-652
3. manual driver install using atheros
4. enable windows wireless manager

Is that correct ?
Logged

davevt31

  • Level 9 Member
  • ****
  • Posts: 1517
Re: DWA-652 slow * cpu at 100%
« Reply #2 on: October 22, 2008, 04:44:05 AM »

I have 3 systems using DLink wireless, I did NOT use the Dlink Manager on any of them just the drivers.  I let Windows handle the Network Connection.  Just point the Device Manager to the folder that contains the driver files and you will be fine.
Logged

Frioniel0801

  • Guest
Re: DWA-652 slow * cpu at 100%
« Reply #3 on: October 22, 2008, 10:20:57 AM »

Ok thanks working on it.

2 things:

1. I enabled windows zero config for my wireless manager. Now i've change it's status to start and to have to run 'automatic'; however, when i reboot my computer the settings changed back to 'stopped' and disable. How can I keep it from reverting back ?

2. The internet runs much faster now, but it still seems sluggish trying to get to a website, but once it's there it loads quite fast. I'm just not sure if this is normal, since my internal card seemed to have got around much faster. Thanks !
Logged

davevt31

  • Level 9 Member
  • ****
  • Posts: 1517
Re: DWA-652 slow * cpu at 100%
« Reply #4 on: October 22, 2008, 11:08:23 AM »

On my wired connection so trying to remember this from inside my head.  If you open the Wireless Connection manager  or from the View Wirless Connections menu, select adjust advanced properties on the left side of the box.  When the properties box opens up make sure the let Windows handle Wireless connections box is checked on the top, then select your network in the bottom box and select propeties.  On one of the tabs look for always connect to this network when in range and connect even when network is not broadcasting (may not be the exact wording but close)
Logged

Frioniel0801

  • Guest
Re: DWA-652 slow * cpu at 100%
« Reply #5 on: October 22, 2008, 11:30:35 PM »

Hi. Sorry, let me reword it.

I have to go into run > services.msc > start windows zero config (set it to automatic also)

Which then allows me to use it for my wireless manager. But when I reboot my computer, the setting goes back to the dell wireless manager one only.

1. Any reason why it's reverting ? Should I disable my dell wireless ?

My CPU still occasionally shoots up to 80% while i'm browsing the web. Current I have atheros driver installed and using the Windows Zero Config and not the D-link wireless manager.

2. ANy reason why it's sucking up CPU usage at times ?
« Last Edit: October 22, 2008, 11:43:00 PM by Frioniel0801 »
Logged

davevt31

  • Level 9 Member
  • ****
  • Posts: 1517
Re: DWA-652 slow * cpu at 100%
« Reply #6 on: October 23, 2008, 08:48:55 AM »

You didn't mention the Dell Wireless earlier, yes I would try with that disabled.  Since it was the first NIC in the machine it is most likely taking priority over the newer DLink one.
Logged

Frioniel0801

  • Guest
Re: DWA-652 slow * cpu at 100%
« Reply #7 on: October 24, 2008, 01:17:39 AM »

Disabled it and now Win Zero Config works fine.

I called d-link today and asked about CPU usage issues and they said that there's nothing that can be done and they are working on an update for it . . .

I spend close to $70 for this and I can't game or surf without getting it. Please help if anyone have a solution. Thanks !
Logged

rayvyn

  • Level 1 Member
  • *
  • Posts: 23
Re: DWA-652 slow * cpu at 100%
« Reply #8 on: November 06, 2008, 08:43:10 AM »

When you check the task Manager, which process is taking up your CPU?
Logged

Lycan

  • Administrator
  • Level 15 Member
  • *
  • Posts: 5335
Re: DWA-652 slow * cpu at 100%
« Reply #9 on: November 06, 2008, 08:52:15 AM »

Update the driver. We've corrected this in later versions.
Logged

Frioniel0801

  • Guest
Re: DWA-652 slow * cpu at 100%
« Reply #10 on: November 06, 2008, 09:42:31 PM »

I'm using the latest atheros driver. Or does that mean i should switch to the 1.40 ver ?
Logged

Lycan

  • Administrator
  • Level 15 Member
  • *
  • Posts: 5335
Re: DWA-652 slow * cpu at 100%
« Reply #11 on: November 10, 2008, 09:15:04 AM »

You can do that. The 1.40 dlink driver has a native "domain" support feature implemented in the dlink utility, but if you just use the driver you should be ok.
Logged

ttmcmurry

  • Level 4 Member
  • ****
  • Posts: 438
Re: DWA-652 slow * cpu at 100%
« Reply #12 on: November 20, 2009, 03:22:48 PM »

I've noticed this problem on a ThinkPad R50 with Windows 7 RTM 32-bit and the DWA-652.  I get about ~4MB/sec out of it, but 100% cpu with only Windows Explorer open & moving files.   

The connection rate is 240mbit & 96% signal (at ~4ft) from the DIR-655 (1.32beta) router.

Win7 has chosen the "Atheros Communications Inc." driver v8.0.0.171 7/8/2009.
« Last Edit: November 20, 2009, 03:25:31 PM by ttmcmurry »
Logged