D-Link Forums

D-Link Wireless Access Points For Business => DAP-2695 => Topic started by: Z918273645 on March 18, 2018, 02:30:17 PM

Title: 403 when accessing my DAP-2695 per hostname
Post by: Z918273645 on March 18, 2018, 02:30:17 PM

Lately I have started to experiment with certificates for network devices such as my DAP-2695. Not out of any real necessity but for educative purposes :-)

After some googling, I managed to install a self-signed certificate on it.

But when I tried to access its web GUI by means of https, I ran into a weird issue, which persists both with https and standard http:
When accessing it by means of a hostname, I run into a 403 http error, both with http and https.
When accessing it on the other hand by means of its IP address, it basically works. However, with https my browser complains about non-matching certificate (FQDN vs. IP address), which kind of voids the use of certificates.

The IP address and other network settings of the DAP-2695 are manually configured. Since it has no input field for a hostname, the AP is not "aware" of  its hostname/FQDN.
Is that the root cause? Could it work if I used DHCP and assigned a hostname along with the other parameters?