• July 18, 2024, 11:03:27 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: LAND ATTACK  (Read 7188 times)

Devoldo

  • Level 1 Member
  • *
  • Posts: 4
LAND ATTACK
« on: February 27, 2010, 04:06:00 PM »

I bought my DGL-4500 about 4 days ago. I have had no other real issues aside from aim punting me off once in a great while (firmware 1.21na factory flashed) (never happened with my old router). I noticed a strange log entry:

Blocked packet from 192.168.0.1 to 192.168.0.1 (LAND Attack)

Above message repeated 277 times

I was curious as to why this entry keeps popping up.

My set-up is as follows:

Modem-DGL-4500-DGL-4300 (with DHCP server off, IP assigned as 192.168.0.199, everything else disabled)-two computers running vista/Windows 7

I'm pretty sure it would have to do with my 4300 acting as a hub with wireless enabled. Any information is greatly appreciated.
Logged

Wastedfreak

  • Level 1 Member
  • *
  • Posts: 23
Re: LAND ATTACK
« Reply #1 on: February 27, 2010, 04:19:29 PM »

what is the IP Address of the 4300 router?? did u disable the DHCP Server of the 4300??
Logged

Devoldo

  • Level 1 Member
  • *
  • Posts: 4
Re: LAND ATTACK
« Reply #2 on: February 27, 2010, 04:32:17 PM »

what is the IP Address of the 4300 router?? did u disable the DHCP Server of the 4300??

192.168.0.199 and yes, DHCP is disabled as stated on my initial post  ;D
Logged

Wastedfreak

  • Level 1 Member
  • *
  • Posts: 23
Re: LAND ATTACK
« Reply #3 on: February 27, 2010, 04:37:46 PM »

The connection is LAN to LAN?? make sure that the Enable DNS Relay is enable. :D
Logged

Devoldo

  • Level 1 Member
  • *
  • Posts: 4
Re: LAND ATTACK
« Reply #4 on: February 27, 2010, 04:57:37 PM »

Enabled DNS relay is enabled. I have re-checked the settings on the DGL-4300 to make sure there was no conflict between the 4500 and 4300. I have the 4300 set-up as a switch. Nothing is connected to the 4300's wan port. The 4500 is the device that keeps spitting up that warning in the log over and over again.
Logged

Wastedfreak

  • Level 1 Member
  • *
  • Posts: 23
Re: LAND ATTACK
« Reply #5 on: February 27, 2010, 05:14:42 PM »

a LAND attack is a DoS attack. Please reference the following link from wiki.

http://en.wikipedia.org/wiki/LAND
Logged

Wastedfreak

  • Level 1 Member
  • *
  • Posts: 23
Re: LAND ATTACK
« Reply #6 on: February 27, 2010, 05:19:53 PM »

http://forums.dlink.com/index.php?action=printpage;topic=2726.0
Logged

Devoldo

  • Level 1 Member
  • *
  • Posts: 4
Re: LAND ATTACK
« Reply #7 on: February 28, 2010, 01:34:52 PM »

Ah, I seemed to have fixed the annoying warning log entry. I changed the IP address of the the AP to 192.168.0.2, and added the mac address in the DHCP reservation list on the DGL-4500. I also shut off DNS relay on the AP and any firewall settings I could find. Then enabled anti-spoofing on the 4500. Everything seems golden now, thanks for the help regardless  ;)
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49923
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: LAND ATTACK (RESOLVED)
« Reply #8 on: March 01, 2010, 07:22:21 AM »

Glad you got it fixed. Hope it works well. Have a great week.
Logged
Cable: 1Gb/50Mb>NetGear CM1200>DIR-882>HP 24pt Gb Switch. COVR-1202/2202/3902,DIR-2660/80,3xDGL-4500s,DIR-LX1870,857,835,827,815,890L,880L,868L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L,960L and 8000LH.