• January 19, 2022, 06:48:25 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  


This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Red Power Light and doesnt working  (Read 2789 times)


  • Level 1 Member
  • *
  • Posts: 1
Red Power Light and doesnt working
« on: January 04, 2016, 08:38:02 PM »

I have a pair of DCS-5020L Cameras, but they are not working, just the power led is on red and doesnt work.

If i reset the cameras they do a self test, but at the final, the lens stay in the center and nothing else happens

Ive tried to reset the camera but nothing happens
ive tried with the ethernet cable plugged and unplugged, but nothing happens yet

Please, Need help!!


  • Poweruser

  • ▲▲
  • *****
  • Posts: 49885
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Red Power Light and doesnt working
« Reply #1 on: January 05, 2016, 10:51:35 AM »


  • What Hardware version is your DCS? Look at the sticker behind or under the camera.
  • Link>What Firmware version is currently loaded? Found on the DCSs web page under status.
  • What region are you located?

What Mfr and model is the main host router?
What wireless modes are you using?
What is the distance between the Camera and the main host router?

Try connecting the cameras via LAN wired after doing a factory reset. Does the camera get a IP address from the main host router?

Test cameras with uPnP and uPnP Port Forwarding both enabled on ALL cameras: DCS Cloud (L) Series Camera Configuration and Mydlink.com
Cable: 1Gb/50Mb>NetGear CM1200>DIR-882>HP 24pt Gb Switch. COVR-1202/2202/3902,DIR-2660/80,3xDGL-4500s,DIR-LX1870,857,835,827,815,890L,880L,868L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L,960L and 8000LH.