• July 20, 2024, 12:58:29 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  


This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: DAP-1520 Extender connected but no Internet  (Read 8266 times)


  • Level 1 Member
  • *
  • Posts: 1
DAP-1520 Extender connected but no Internet
« on: February 21, 2020, 05:41:44 AM »

Hi, so I think this is a recent issue but I can't be sure since I've installed the DAP-1520 at my dads place and he isn't very tech savy... but I think it was working when I installed it a year or two ago.
I'm using two DAP-1520 daisy chaining the connection downstairs and then the endpoint extender wasn't working anymore so I tried to redo the setup but while doing so also the other one had a problem and now I can't even get an internet connection with either of them connected to the main router.

Are there any special settings I should be aware of when daisy chaining two extenders ? (in case I get the first connection to work again)

At the moment I only have some mobile devices available for testing but I also tried to extend a mobile hotspot with one of the extenders and had the same problem.
Actually I left it running for a bit and the extended mobile hotspot works fine but extending the home wifi still does not

They are both H/W VER.: A1 and F/W VER.: 1.06
My main router is a: ARRIS model: TG82S
I'm located in Austria

It seems like this is an unsupported product but I hope someone can help.
« Last Edit: February 21, 2020, 06:02:18 AM by dragb0t »


  • Administrator
  • Level 11 Member
  • *
  • Posts: 2752
Re: DAP-1520 Extender connected but no Internet
« Reply #1 on: February 21, 2020, 06:59:07 AM »

You have 2 extenders?

Like this?     router  ( ( (  ) ) ) extender 1  ( ( ( ) ) )  extender 2

Do both extenders have a green leds?

Can you ping the router? If yes then the extender is successfully connected.

Can you ping an IP address on the Internet (try  If yes, you have internet access. Can you ping a website (try yahoo.com)? if no, it is a DNS issue.