• December 04, 2021, 08:31:53 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: DSP-W110 Login stopped working  (Read 4507 times)

guice

  • Level 1 Member
  • *
  • Posts: 3
DSP-W110 Login stopped working
« on: January 22, 2020, 01:51:59 PM »

I don't know why, but logging into these directly no longer seem to work.

I go to: 192.168.0.40, login with Admin/[pin] and I'm prompted with "ERROR"

 - When I view Network activity, I see a POST to `/HNAP1/` for "request" Action, contains username with empty LoginPassword. Returns a user cookie and a Challenge
 - Second `/HNAP1/` call that contains Login Action, username, and encoded password. Returns error "ERROR"

These PINs are right, straight off the back of the devices. Any idea what's going on?

Device Info:
Code: [Select]
      <GetDeviceSettingsResult>OK</GetDeviceSettingsResult>
      <Type>ConnectedHomeClient</Type>
      <DeviceName>Terrarium</DeviceName>
      <VendorName>D-Link</VendorName>
      <ModelDescription>D-Link Socket</ModelDescription>
      <ModelName>DSP-W110</ModelName>
      <DeviceMacId>90:8D:78:E0:1A:80</DeviceMacId>
      <FirmwareVersion>2.04</FirmwareVersion>
      <FirmwareRegion>Default</FirmwareRegion>
      <LatestFirmwareVersion/>
      <HardwareVersion>B1</HardwareVersion>
      <HNAPVersion>0124</HNAPVersion>
      <PresentationURL>http://dsp.local</PresentationURL>
      <CAPTCHA>false</CAPTCHA>
      <ModuleTypes>
        <string>Smart Plug</string>
      </ModuleTypes>
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49865
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: DSP-W110 Login stopped working
« Reply #1 on: January 22, 2020, 02:06:40 PM »

What browser are you using? Try IE11 or Firefox ESR v52.9.0.
Logged
Cable: 1Gb/50Mb>NetGear CM1200>DIR-882>HP 24pt Gb Switch. COVR-1202/2202/3902,DIR-2660/80,3xDGL-4500s,DIR-LX1870,857,835,827,815,890L,880L,868L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L,960L and 8000LH.

guice

  • Level 1 Member
  • *
  • Posts: 3
Re: DSP-W110 Login stopped working
« Reply #2 on: January 23, 2020, 03:29:09 PM »

So, after unplugging in the device so I can bring it upstairs to debug it, things have started working ....

Turns out, for some unknown reason, a reboot (of the device) was needed, even though they worked just fine in the app. My own REST calls via Paw (Postman-like), have started working, too!

There was definitely something "buggered" on the devices. I had to boot both of them, and they now work!
« Last Edit: January 23, 2020, 03:31:49 PM by guice »
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49865
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: DSP-W110 Login stopped working (RESOLVED)
« Reply #3 on: January 24, 2020, 06:18:35 AM »

May have got in to a bad state is all. Glad they are working now. Enjoy.  ;)
Logged
Cable: 1Gb/50Mb>NetGear CM1200>DIR-882>HP 24pt Gb Switch. COVR-1202/2202/3902,DIR-2660/80,3xDGL-4500s,DIR-LX1870,857,835,827,815,890L,880L,868L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L,960L and 8000LH.

guice

  • Level 1 Member
  • *
  • Posts: 3
Re: DSP-W110 Login stopped working
« Reply #4 on: January 29, 2020, 12:01:12 PM »

Well, that bad state seems to be happening often.

They died again.... and I have to manually unplug/replug them to put them back into their normal state. :/

PS: these forums aren't emailing me of updates .... hmm.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49865
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: DSP-W110 Login stopped working
« Reply #5 on: January 30, 2020, 06:01:31 AM »

I recommend that you phone contact your regional D-Link support office and ask for help and information regarding this.
Link> Tech Support Contact Information
We find that phone contact has better immediate results over using email.
Let us know how it goes please.
Logged
Cable: 1Gb/50Mb>NetGear CM1200>DIR-882>HP 24pt Gb Switch. COVR-1202/2202/3902,DIR-2660/80,3xDGL-4500s,DIR-LX1870,857,835,827,815,890L,880L,868L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L,960L and 8000LH.