• February 19, 2018, 01:51:49 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Ports 80 and 443 not forwarded  (Read 1590 times)

flasher

  • Level 1 Member
  • *
  • Posts: 3
Ports 80 and 443 not forwarded
« on: December 31, 2016, 03:24:56 AM »

Hello,
recently I bought Synology NAS and I'm trying to make it available from outside of my network. First of all I let Synology to configure my router automatically. All ports used by Synology are accessible from the Internet except ports 80 and 443. When using NMAP, all used ports are marked as "open" while 80 and 443 are marked as "filtered". So I disabled UPnP on the router and tried to configured the forwarding rules manually (tried both Virtual Server and Port Forwarding). The result is the same, 80 and 443 not available, others working fine.

Afterwards I contacted my ISP to ask whether these ports are blocked in their side - answer is no.

I alsi tried to check these ports on the Synology directly in my internal network and both ports are open on the device. So my assumption is that the port forwarding for these 2 ports does not work for some reason. Very strange is that I have an issue just with these 2 ports.

I tried to change configuration which might affect blocking of those ports (I have no application rules, no QoS engine enabled, no network filter, no access control, no IPv6, ...), but no success. Adding the Synology to DMZ has also no effect, 80 and 443 not visible there using NMAP, other ports are fine.

So conclusion is: I'm sure that both ports are open and available within my internal network on the Synology, but from outside (Internet), these ports are not forwarded.

I use D-Link DIR-868L with FW 1.09 and HW version A1.

Do you have any ideas what might be wrong?  I'm really out of options.

Thanks!
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 44550
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Re: Ports 80 and 443 not forwarded
« Reply #1 on: December 31, 2016, 12:46:01 PM »

Link>Welcome!

  • What region are you located?

Router and Wired Configurations
  • Turn on or off DNS Relay under Setup/Networking. Link>Finding Faster DNS Addresses using Name Bench and input new DNS addresses under Setup/Internet/Manual.
  • Setup DHCP reserved IP addresses for all devices ON the router. Setup/Networking. This ensures each devices gets its own IP address when turned on and connected, eliminates IP address conflicts and helps in troubleshooting and maintain consistency for applications that need to connect as well as mapped drives.
  • Ensure devices are set to auto obtain an IP address.
  • If IPv6 is an option on the router, select Local Connection Only under Setup/IPv6.
  • Set Firewall settings to Endpoint Independent for TCP and UDP under Advanced/Firewall. Enable or Disable SPI to test.
  • Enable uPnP and Multi-cast Streaming under Advanced/Networking. Disable uPnP for testing Port Forwarding rules.

Please post a picture of your Port Forwarding configuration:
Adding Screenshots In A Post
« Last Edit: December 31, 2016, 12:48:06 PM by FurryNutz »
Logged
Cable:200mb/10Mb>Motorola MB7420>COVR3902>HP 24pt Gb Switch. 3xDGL-4500s,DIR-857,835,827,815,890L,880L,868L,865L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

flasher

  • Level 1 Member
  • *
  • Posts: 3
Re: Ports 80 and 443 not forwarded
« Reply #2 on: January 01, 2017, 12:42:02 PM »

I'm located in Europe (Czech Republic).

DNS Relay - no effect
Reserved IP addresses - done, no effect
All devices set to obtain an IP address - done, no effect
IPv6 Local Connection Only set - no effect
Firewall settings to Endpoint Independent - no such option in the configuration page
SPI enabled / disabled - no effect
uPnP and Multi-cast Streaming enabled / disabled - no effect

I tried to set the forwarding rules via uPnP and also manually with uPnP disabled but the result is the same.

192.168.0.101 is reserved address for my Synology



Is there any way how to find out which rules were set by uPnP?
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 44550
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Re: Ports 80 and 443 not forwarded
« Reply #3 on: January 01, 2017, 12:49:39 PM »

Try using a different private port number, like 50117? I believe that with using Virtual Server, uPnP should be enabled and use a virtual port number that isn't the same as the public port number...

Is the 868L getting a public IP address on the WAN port? ##.##.###.###

Might try v1.10 update as well...
« Last Edit: January 01, 2017, 12:54:43 PM by FurryNutz »
Logged
Cable:200mb/10Mb>Motorola MB7420>COVR3902>HP 24pt Gb Switch. 3xDGL-4500s,DIR-857,835,827,815,890L,880L,868L,865L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

flasher

  • Level 1 Member
  • *
  • Posts: 3
Re: Ports 80 and 443 not forwarded
« Reply #4 on: January 02, 2017, 12:52:21 AM »

Using different private port number does not work either, the 80 an 443 are simply not accessible from outside. The forwarding works for other ports so I don't think this is general forwarding problem.

Yes, I have public IP on WAN interface.

Isn't the port blocked by the router administration UI for some strange reason? It also runs on port 80 (and optionally 443 with HTTPS), rigth?

Where can I find the v1.10 update?

Thanks
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 44550
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Re: Ports 80 and 443 not forwarded
« Reply #5 on: January 02, 2017, 09:51:26 AM »

Check with your regional D-Link support site. I believe it's there. If it still fails, then there maybe a FW issue and I would recommend that you phone contact your regional D-Link support office and ask for help and information regarding this. We find that phone contact has better immediate results over using email.
Let us know how it goes please.
« Last Edit: January 18, 2018, 02:38:35 PM by FurryNutz »
Logged
Cable:200mb/10Mb>Motorola MB7420>COVR3902>HP 24pt Gb Switch. 3xDGL-4500s,DIR-857,835,827,815,890L,880L,868L,865L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 44550
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Re: Ports 80 and 443 not forwarded
« Reply #6 on: January 18, 2018, 02:39:04 PM »

Any status on this?  ???

Using different private port number does not work either, the 80 an 443 are simply not accessible from outside. The forwarding works for other ports so I don't think this is general forwarding problem.

Yes, I have public IP on WAN interface.

Isn't the port blocked by the router administration UI for some strange reason? It also runs on port 80 (and optionally 443 with HTTPS), rigth?

Where can I find the v1.10 update?

Thanks
Logged
Cable:200mb/10Mb>Motorola MB7420>COVR3902>HP 24pt Gb Switch. 3xDGL-4500s,DIR-857,835,827,815,890L,880L,868L,865L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting