• November 18, 2017, 02:28:00 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Pages: 1 [2] 3

Author Topic: FireFox 52 + NCSPlugin (DO NOT UPDATE FF BROWSER!!!)  (Read 8231 times)

Champion

  • Level 1 Member
  • *
  • Posts: 17
Re: FireFox 52 + NCSPlugin (DO NOT UPDATE FF BROWSER!!!)
« Reply #15 on: March 12, 2017, 05:04:15 AM »

they removed compatibility npapi plugin so all netscape based plugins (NCSPlugin, mydlink-Plugin (but even java, adobe pdf) arnt supported from firefox 52. due to give adobe flash a chance (even if they decided 2015 to remove the plugin) the npapi is still in firefox 52 but "switched off" (only flash is allowed).
BUT in the COMMING firefox 53 the plugin shoud be removed.
SO you can NOW switch it back on (and risk old outdated plugins) and use dlink till they solved the pluginproblem) or download a special firefox version and hope that dlink will provide a solution until firefox 53 ist ready to install. so NO: it's not over; dlink has a short period to develop a new plugin und we still can use our firefox 52 without installing a new version. But with firefox 53 it should be over ;-)

hope dlink has a huge amount of programers; now they have a plugin problem and a security problem.... and without working plugins no mydlink and no chance to "We suggest that D-Link customers register and use the mydlink cloud services in order to promptly receive the most updated firmware."...

So as we say it in Austria: da beisst der Hund sich in den Schwanz....
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 43623
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Re: FireFox 52 + NCSPlugin (DO NOT UPDATE FF BROWSER!!!)
« Reply #16 on: March 12, 2017, 11:03:55 AM »

I'm sure D-Link is aware of all the issues that now surround FF and Plug-ins.

Users are advised that IE11 for Windows and Safari for Mac are still supporting plug-ins and work with D-Link Plug-in for MDL services. I believe Chrome is still working as well however I don't use Chrome.

If your in Austria, I recommend that you phone contact your regional D-Link support office and ask for help and information regarding this. Reference this forum thread as well. We find that phone contact has better immediate results over using email.
Let us know how it goes please.

Logged
Cable:100mb/3Mb>Motorola SB6183>COVR3902>HP 24pt Gb Switch. 3xDGL-4500s,DIR-857,835,827,815,890L,880L,868L,865L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 43623
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Re: FireFox 52 + NCSPlugin (DO NOT UPDATE FF BROWSER!!!)
« Reply #17 on: March 13, 2017, 10:46:10 AM »

From what I've been told, users will need to install FF v5x ESR version of the browser that supports plug-ins and following the linked FAQ this this thread for users wishing to use FF browser with D-Link and mydlink supported products.
Logged
Cable:100mb/3Mb>Motorola SB6183>COVR3902>HP 24pt Gb Switch. 3xDGL-4500s,DIR-857,835,827,815,890L,880L,868L,865L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

AntonyDu92

  • Level 1 Member
  • *
  • Posts: 2
Re: FireFox 52 + NCSPlugin (DO NOT UPDATE FF BROWSER!!!)
« Reply #18 on: March 18, 2017, 10:06:28 AM »

FF v5x ESR, hmmm.. probably only FF v52 ESR, so, probably in one year this "ESR" workaround won't be the solution anymore.
https://www.mozilla.org/en-US/firefox/organizations/faq/
And same problem with Chrome : i can't do the "enable NPAPI" workaround with my chrome version 57.
NPAPI is a technology born in the nineties.
http://www.infragistics.com/community/blogs/devtoolsguy/archive/2015/02/16/no-more-npapi-support-for-chrome-what-are-the-alternatives.aspx
Who is to blame ? Chrome and firefox ?
Noooo : before they do this, for good reasons, they warn long before to do it (example : Chrome annoucement in 2013!), and when they do it, they do it progressive (first a trick is possible, then not possible).
Dlink should have work on the subject since 2013, but probably they work on this only now.. If they really work on it.. Maybe they think that they can just require FF 52 ESR and then in 2018 Q2 they will say "buy our new dlink camera"..
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 43623
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Re: FireFox 52 + NCSPlugin (DO NOT UPDATE FF BROWSER!!!)
« Reply #19 on: March 18, 2017, 12:11:25 PM »

Google and Mozilla are sole responsible for there browsers and what they choose to support. It's up to D-Link I presume to either find alternatives and talk with Google and Mozilla on development solutions for D-Link products. At this time either use the FF solution until D-Link comes up with a different solution to work with FF and Chrome or use IE11. IE11 for Windows and Safari for Mac is working for me with my DCS-933L and 960L and my other cloud devices. Im sure other Mfrs are having similar issues with there plug-ins since D-Link isn't the only one using plug-ins.

I'm sure all of this will develop into some other form and D-Link will develop something else that may or may no longer be browser dependent.

There are other D-Link apps that support remote viewing, mobile and PC based that are not plug-in or browser dependent!

Good Luck.
Logged
Cable:100mb/3Mb>Motorola SB6183>COVR3902>HP 24pt Gb Switch. 3xDGL-4500s,DIR-857,835,827,815,890L,880L,868L,865L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 43623
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Logged
Cable:100mb/3Mb>Motorola SB6183>COVR3902>HP 24pt Gb Switch. 3xDGL-4500s,DIR-857,835,827,815,890L,880L,868L,865L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

dougb

  • Level 1 Member
  • *
  • Posts: 1
Re: FireFox 52 + NCSPlugin (DO NOT UPDATE FF BROWSER!!!)
« Reply #21 on: March 21, 2017, 07:04:41 PM »

NPAPI has been on its way out for a very long time - D-Link should have planned for this a long time ago and started working on replacements for any of their applications, applets, plug-ins, or anything that relies on NPAPI. Chrome removed support for NPAPI like a year ago. It's an insecure way to integrate to the browser, and there are multiple options for integrating in more secure ways.

I certainly hope D-Link is actively working on updating things. I have essentially lost the ability to use a browser to work with pretty much all six of my cameras, and my NVR-312L.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 43623
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Re: FireFox 52 + NCSPlugin (DO NOT UPDATE FF BROWSER!!!)
« Reply #22 on: March 22, 2017, 07:15:58 AM »

IE11 for Windows and Safari for Mac is working for me with my DCS-933L and 960L and my other cloud devices.

NPAPI has been on its way out for a very long time - D-Link should have planned for this a long time ago and started working on replacements for any of their applications, applets, plug-ins, or anything that relies on NPAPI. Chrome removed support for NPAPI like a year ago. It's an insecure way to integrate to the browser, and there are multiple options for integrating in more secure ways.

I certainly hope D-Link is actively working on updating things. I have essentially lost the ability to use a browser to work with pretty much all six of my cameras, and my NVR-312L.
Logged
Cable:100mb/3Mb>Motorola SB6183>COVR3902>HP 24pt Gb Switch. 3xDGL-4500s,DIR-857,835,827,815,890L,880L,868L,865L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

Kezzz

  • Level 1 Member
  • *
  • Posts: 1
Re: FireFox 52 + NCSPlugin (DO NOT UPDATE FF BROWSER!!!)
« Reply #23 on: March 23, 2017, 01:43:23 PM »

There is now a NOTE about the FF deprecation once you login to myDLink from IE or Chrome. Here is the link ...
https://www.mydlink.com/faq#id-key_263/ans-235
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 43623
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Re: FireFox 52 + NCSPlugin (DO NOT UPDATE FF BROWSER!!!)
« Reply #24 on: March 23, 2017, 02:10:46 PM »

Yes, this is the same as my earlier post on the 10th.
FF ESR is the current work around for this issue.
Also IE11 for Windows and Safari for OSX is still supported fully and working.  ;)

Thank you.

There is now a NOTE about the FF deprecation once you login to myDLink from IE or Chrome. Here is the link ...
https://www.mydlink.com/faq#id-key_263/ans-235
« Last Edit: March 23, 2017, 02:15:49 PM by FurryNutz »
Logged
Cable:100mb/3Mb>Motorola SB6183>COVR3902>HP 24pt Gb Switch. 3xDGL-4500s,DIR-857,835,827,815,890L,880L,868L,865L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

Morgana

  • Level 1 Member
  • *
  • Posts: 1
Re: FireFox 52 + NCSPlugin (DO NOT UPDATE FF BROWSER!!!)
« Reply #25 on: March 25, 2017, 08:32:12 PM »

I have a DCS5020L Cam, it do not work with Firefox 52 (released March 2017).
I tried several web browsers, the only one that works is Internet Explorer 11, but you have to do the following steps:
1) Update the camera firmware
2) Install the latest version of Java (Version 8 update 121)

Now everything works very well.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 43623
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Re: FireFox 52 + NCSPlugin (DO NOT UPDATE FF BROWSER!!!)
« Reply #26 on: March 25, 2017, 08:34:44 PM »

IE11 works. Also you can use the FF ESR version with the plug in.

Enjoy.
Logged
Cable:100mb/3Mb>Motorola SB6183>COVR3902>HP 24pt Gb Switch. 3xDGL-4500s,DIR-857,835,827,815,890L,880L,868L,865L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

wired1979

  • Level 1 Member
  • *
  • Posts: 14
Re: FireFox 52 + NCSPlugin (DO NOT UPDATE FF BROWSER!!!)
« Reply #27 on: March 28, 2017, 08:55:58 AM »

There is now a NOTE about the FF deprecation once you login to myDLink from IE or Chrome. Here is the link ...
https://www.mydlink.com/faq#id-key_263/ans-235

So the question is will D-Link ever support the new Firefox Web APIs?
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 43623
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Re: FireFox 52 + NCSPlugin (DO NOT UPDATE FF BROWSER!!!)
« Reply #28 on: March 28, 2017, 09:11:46 AM »

Don't get that kind of info. I presume D-Link is aware of all things and they will determine when and where things will go.

Something you can ask them as well.  ;)
Logged
Cable:100mb/3Mb>Motorola SB6183>COVR3902>HP 24pt Gb Switch. 3xDGL-4500s,DIR-857,835,827,815,890L,880L,868L,865L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 43623
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Logged
Cable:100mb/3Mb>Motorola SB6183>COVR3902>HP 24pt Gb Switch. 3xDGL-4500s,DIR-857,835,827,815,890L,880L,868L,865L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting
Pages: 1 [2] 3