• November 19, 2017, 12:42:56 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Pages: [1] 2 3
  Subject Started by Replies Views Last post
United States Support and FAQ's Here! arod 0 5275 Last post January 19, 2009, 01:15:50 PM
by arod
New D-Link Web Sites - USA FurryNutz 1 39459 Last post March 07, 2013, 10:30:47 AM
by FurryNutz
300Mbps Connection Requirements! Please Read! Lycan 0 11830 Last post November 07, 2007, 09:38:50 AM
by Lycan
Welcome! Lycan 0 4187 Last post October 16, 2007, 09:30:06 AM
by Lycan
DWA-140 always disabled in Windows 7 adds21 4 7685 Last post August 07, 2010, 09:26:35 PM
by rcoloma
DWA-140 questions. Adiemus 2 3914 Last post August 26, 2010, 06:57:54 PM
by !!!!clarkkent
What's the Real Range of DWA-140? Alifak1 1 3181 Last post October 01, 2010, 06:25:00 AM
by rcoloma
DWA-140 drops connection Bashy 7 13468 Last post January 05, 2010, 05:21:35 PM
by ozzed3
DWA 140 Lag Spikes bobbydazla 9 5435 Last post July 15, 2014, 12:26:17 PM
by FurryNutz
10 Digit Hex Key Bravecone 0 2807 Last post February 23, 2011, 11:22:30 AM
by Bravecone
Confusing Differences Among Ralink Drivers Bulldog 2 4287 Last post February 02, 2010, 12:46:38 PM
by Bulldog
Driver DWA-140 for H/W:A3 burnerth 3 12896 Last post August 13, 2013, 07:17:05 AM
by FurryNutz
Adhoc mode between DWA556 and DWA140 only at 54Mbps clyde 2 6888 Last post December 20, 2008, 02:06:38 PM
by PeterJvM
DWA-140 RevB1 does not work with Win7 64bit « 1 2 » DBR 18 90946 Last post March 26, 2012, 10:00:25 PM
by avionwbt
The Best dudepr 0 3228 Last post May 05, 2008, 08:39:12 PM
by dudepr
Update firmware, ? dumpystig 8 11793 Last post May 09, 2011, 11:04:21 AM
by altair_xms
IP Address Host Issues - DWA 140 emorr1 1 5024 Last post July 28, 2014, 08:52:20 AM
by FurryNutz
Only 54 Mbps in Windows7 64 bit e_ddi_e 2 4467 Last post February 28, 2010, 11:21:27 AM
by Wastedfreak
DWA-140 Rev. B2 link speed problems gfx8 1 9120 Last post May 07, 2011, 02:15:31 AM
by paulgj
Unusual Connection Issue! gspeer2 1 2275 Last post August 23, 2012, 08:12:03 AM
by FurryNutz
Pages: [1] 2 3

 

  • Normal Topic
  • Hot Topic (More than 15 replies)
  • Very Hot Topic (More than 25 replies)
  • Locked Topic
  • Sticky Topic
  • Poll