• July 26, 2017, 09:41:29 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Pages: [1] 2
  Subject Started by Replies Views Last post
New D-Link Web Sites - USA FurryNutz 1 40911 Last post March 07, 2013, 10:31:03 AM
by FurryNutz
DWA-142 - EOL FurryNutz 0 18653 Last post November 28, 2012, 12:30:12 PM
by FurryNutz
United States Support and FAQ's Here! arod 0 5047 Last post January 19, 2009, 01:16:58 PM
by arod
300Mbps Connection Requirements! Please Read! Lycan 0 3672 Last post November 07, 2007, 09:38:33 AM
by Lycan
Welcome! Lycan 0 3383 Last post August 30, 2007, 04:53:33 PM
by Lycan
x64 drivers coming? Thorgils 2 62423 Last post May 23, 2011, 12:35:30 PM
by RaZor87
Failed install...bad connections et al. marmoduke 0 11877 Last post July 01, 2010, 10:21:31 AM
by marmoduke
failed to install kathykearny 2 4825 Last post July 01, 2010, 10:17:35 AM
by marmoduke
Unable to connect to Internet alanrichey 4 11420 Last post February 08, 2010, 12:49:58 AM
by alanrichey
Full N not Draft Stepan 0 5950 Last post December 07, 2009, 12:56:36 PM
by Stepan
Cannot find driver for DWA-142 poolboynaturel 1 7235 Last post October 12, 2009, 11:32:43 AM
by kevinla
Install HANGS on Windows XP-SP2 using Latest Driver from Webpage markt5233 1 4172 Last post October 06, 2009, 12:49:09 PM
by kevinla
Wireless Connection Manager not working and connection drops bhav27 1 9867 Last post August 26, 2009, 02:59:13 PM
by kevinla
Windows 7 Drivers? TheNewZackMorris 0 6208 Last post July 17, 2009, 04:58:57 AM
by TheNewZackMorris
Blue screen on high network load CadErik 4 7286 Last post July 01, 2009, 05:11:02 PM
by philip
Dropping Connection andy 8 10717 Last post June 01, 2009, 06:27:50 AM
by andy
Wireless Network Connection deleted when connection to wireless router is lost vernsplaza 0 5938 Last post February 18, 2009, 12:36:50 PM
by vernsplaza
Vista x64 Drivers Coming? Mayhemm 14 22387 Last post February 09, 2009, 09:07:54 AM
by arod
Random frequent disconnects with DWA-142 and DIR-625 A1 czachari 7 9276 Last post January 06, 2009, 02:31:54 PM
by arod
New driver version 1.30 fixed the automatic connect from sleep problem for me kevinla 4 6421 Last post December 26, 2008, 08:57:17 PM
by kevinla
Pages: [1] 2

 

  • Normal Topic
  • Hot Topic (More than 15 replies)
  • Very Hot Topic (More than 25 replies)
  • Locked Topic
  • Sticky Topic
  • Poll