• April 11, 2021, 09:24:51 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Cannot access DPR-1260 Wirelessly  (Read 16096 times)

rk555

  • Level 1 Member
  • *
  • Posts: 1
Cannot access DPR-1260 Wirelessly
« on: February 20, 2011, 07:52:42 PM »

I have a 2Wire router. I can access the printer server when it is wired to the router. In wireless setup, the print server does detect my router, and I have set the wireless setting ON. However, once I remove the Ethernet cable, the print server does make itself available in the network. I cannot ping it. I have IP Address set DHCP. I tried Static but then the server could not reboot.

By the way, I have a secured home network, but the print server joined the network without asking for the router password.

Any help/suggestions???

Thanks.
Logged

mik-adl

  • Level 1 Member
  • *
  • Posts: 1
Re: Cannot access DPR-1260 Wirelessly
« Reply #1 on: February 06, 2012, 10:40:30 PM »

I know this post is almost a year old but I had a few issues setting up my DPR-1260 on my wireless network with a DIR-300 access point/router and a search of the web shows many people having issues getting the DPR-1260 to connect to various wireless networks so I thought id share what I found to get mine working.

I scored my DPR-1260 for $11 brand new unopenned off ebay and was disappointed when I couldnt get it to work and even more so when a quick search of the web reveals how many people have problems with this product. No offense to DLink, but their support seems to be very limited, especially if I can work it out and they have not as much as offered anything that I can find!
With extensive experience with wireless networking over the years I was determined to get to the bottom of this.

It seems the DPR-1260 is picky about what encryption setings are used.
I had the 'Searching for AP' issue when the DPR-1260 could see my home network but just wouldnt connect.
With the firmware that came on the router, 1.12 i think it was, it would say it was connected and then go back to Searching for AP every few seconds and the MAC table on the router never saw it so it never connected.
Apon upgrading the firmware to 1.21 (highest revision available outside north america it appears) it would just stay at Searching for AP.
Disabling encyption on router made it connect instantly but there is no way i would run anything less than WAP on my home network.

So I tried various settings on the router and found that the DPR-1260 will not connect if WAP/WAP2 is used with AES encryption selected. Selecting TKIP or TKIP+AES allowed the DPR-1260 to connect.

So after it was able to sucessfully connect to my DIR-300 router with WPA and TKIP/AES working, nonne of my PC's could see it. I have a netbook with XP, Laptop with Vista premium and media center with Win7x64 that I was going to share the printer with.
I noticed the DPR-1260 is a uPnP device so I enabled uPnP on all my machines
(search microsoft support site on how to do this, it is disabled by default in vista and 7 and a security program I ran some time ago deactivated it on my XP machine!)
With uPnP active on all my PC's I still could not see it.

I found an option to activate uPnP support on my router under 'Advanced>Advanced Network>Universal Plug and Play (UPnP) supports peer-to-peer Plug and Play functionality for network devices'
so I enabled it and straight away my XP and Windows 7x64 PC's could see and connect to the DPR-1260.
I have a Brother 2040 attached to the DPR-1260 and had no problem downloading the setup file from the print server and installing the driver.
This leads me to belive that some people have trouble if uPnP is not enabled or supported by the modem/router (more likely the cheaper about the place) as I saw a few people complain their DPR-1260 stopped working after a modem router changeover/upgrade.

But now I could not get my Vista laptop to see the DPR1260. I tried to manually configure tcp/ip connection but every suggestion I could find on google would not work.
I thought a bit deeper, the firewall is usually responsible for allowing/blocking network services.
I am running CA internet security with its own firewall so I disabled the firewall and reactivate the Windows firewall and this allowed the vista laptop to see the DPR-1260 and connect to the printer no worries.
So its all working for now after a day of messing about, only thing left to do is create an exemption for upnp in the ca firewall but windows firewall is good enough.

It sucks the DPR 1260 has very limited wireless security config options, I assume it supporting WPA and WPA2 was a bit of an afterthought as the firmwre 1.12 and earlier only supports none or WEP (which is so easily cracked its not funny).

Also if you are outside North America and have used the firmware v1.24 then its possible the problem you are having is due to incompatibilities in the freqencies allocated to channels.
The DPR-1260 doesnt allow you to select which region you are in like every other wireless product does so one can only assume that the firmware from the correct region already contains this info preconfigured (ie use australian dlink firmware download link for australia).
There is a warning on the north america firmware download page and I can only assume that it is for this reason.

Sucks that this print server is let down by poor firmware confguration and support. Ive always gotten along well with DLink products, this was the first one that threw a bit of a curveball. Theres theories floating around that the product is faulty and their trying to cover it up with firmware patch etc but really it comes down to lack of information required to really get this up and running. Again im surprised that dlink support never released any amendments to the issues everyone was experiencing.
Really I feel there are so many requirements and checks that need to be made before purchasing this product, Id almost say this model is for 'IT related people only' as there is alot of stuff that is just not mentionned or explainned in the manual.

So hope some of this is helpful!  ;D
« Last Edit: February 06, 2012, 10:47:49 PM by mik-adl »
Logged

mmcdowel

  • Level 1 Member
  • *
  • Posts: 1
Re: Cannot access DPR-1260 Wirelessly
« Reply #2 on: August 15, 2014, 04:39:54 PM »

I just wanted to say thanks for the information!  The WAP security setting worked for me with a DIR-825 router.  Also, I had to use Google Chrome instead of IE11 to access the set up pages.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49570
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Cannot access DPR-1260 Wirelessly
« Reply #3 on: August 15, 2014, 05:42:06 PM »

Link>Welcome!

  • What Hardware version is your router? Look at sticker under router.
  • Link>What Firmware version is currently loaded? Found on the routers web page under status.
  • What region are you located?
  • Are you wired or wireless connected to the router?

PC Web Browser Configurations
What browser are you using?
Try Opera or FF? If IE 8, 9, 10 or 11, set compatibility mode and test again.
Disable any security browser Add-ons like No Script and Ad-Block or configure them to allow All Pages when connected to the router.
Clear all browser caches.
Be sure to log into the Admin account on the router.
Try turning off these features in Chrome:
Top right corner, little bars for options > Settings > Settings (on left) > Show advanced settings.
Uncheck these:
Use a web service to help resolve navigation errors
Use a prediction service to help complete searches and URLs typed in the address bar
Predict network actions to improve page load performance
Enable phishing and malware protection

I just wanted to say thanks for the information!  The WAP security setting worked for me with a DIR-825 router.  Also, I had to use Google Chrome instead of IE11 to access the set up pages.
Logged
Cable: 1Gb/50Mb>NetGear CAX80>DIR-882>HP 24pt Gb Switch. COVR-1202/2202/3902,DIR-2660/80,3xDGL-4500s,DIR-857,835,827,815,890L,880L,868L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L,960L and 8000LH.