D-Link Enterprise > DWC-1000 / 2000

DWC-1000 & DWL-7620APs Problem - Can't connect to wireless network



I am setting up a DWC-1000 and some DWL-7620APs.  The APs are provisioned using the DWC-1000, and the APs receive the profiles from the DWC.  My problem is connecting to the wireless network.  I have tried using a windows 10 laptop and an iphone, both can see the SSIDs, but always get the "generic" can not join network, even when trying with a test SSID that is *open* with no security on it.  When I tested with an open SSID and could not connect with neither the WIndows 10 device nor iPhone, it really made me scratch my head... I am at a bit of loss now.  D-Link network equipment is fairly new to me.

Is there some setting that I am missing that would cause this behaviour?

I have tried enabling logs but can not find any relevant information.  Is there a diagnostic tool Ion the DWC-1000 or the DWL-7620APs that would help troubleshoot what is happening?

Any other suggestions for what may be wrong?

Thank you.

Update.  I factory reset one of the DWL-7620AP units and brought up as a stand alone mode. Was then able to connect to it both with open security and WPA2/AES set.  I factory reset the DWC-1000, did the minimal LAN configuration to get it on the network, provisioned the standalone AP to become a managed AP.  Appled the default AP profile, which creates an open SSID with no security.  Guess what.... unable to connect to the SSID.

BTW: all devices have had their firmware upgraded to the latest versions.

Any one out there, can help me?  Thanks.

I recommend that you phone contact your regional D-Link support office and ask for help and information regarding this.
Link> Tech Support Contact Information
We find that chat/phone contact has better immediate results over using email.


[0] Message Index

Go to full version